1. AC Question's Avatar
    Hi everyone, I neve had this issue on my S4, but the S7 just will not retrieve the emails in any timely manner unless I manually sync (which defeats the purpose). I read online that the fix was supposed to have been made a few weeks back, but the S7 clearly wasn't a part of it. Any ideas/suggestions?
    Jose Marvin likes this.
    03-10-2016 04:15 PM
  2. dbdynsty25's Avatar
    Definitely seeing the same behavior.
    03-11-2016 06:04 PM
  3. GadgetsRock's Avatar
    My S7 syncs emails very quickly (and the second that I open or revive it), but in the calendar the old "sync now" is gone. How do I force syncing the calendar?
    03-11-2016 07:46 PM
  4. JasmineHope's Avatar
    I am having the same issues. No app that is supposed to update in real time including Facebook, Weather Channel, Gmail or Android email app syncs automatically. Will this be fixed in an upcoming update? (please!)
    03-24-2016 07:22 PM
  5. BuckeyeBoy77's Avatar
    You need to go into settings -> applications -> application manager -> email -> storage -> clear cache.

    This worked for me
    hdgrlktch likes this.
    03-27-2016 08:53 PM
  6. ckelly33's Avatar
    Still having this issue. The above didn't help at all. Anyone found a fix?
    03-29-2016 07:46 PM
  7. ajb1965's Avatar
    You don't have Gmail optimized (doze) in battery settings by chance do you? Optimizing will halt background tasks like syncing.

    Posted via the Android Central App
    03-29-2016 11:03 PM
  8. ajewellmom's Avatar
    Do you have power saving mode on? I was ready to return my S7 due to email not syncing properly, but when I turned off power saving mode, I was all fixed. This after multiple calls to Rogers . . . nothing like wasted time.
    07-28-2016 11:01 AM
  9. lpauline's Avatar
    THANK YOU SO MUCH ..Have been trying to make Note 7 sync for a week ..including going to Verizon stores & calling Google. I turned off the 'POWER SAVE' & bingo, everything worked immediately. Do you know if this mean there's no way to use the power save option?
    09-01-2016 08:22 PM
  10. lpauline's Avatar
    Whoops ..posted w/wrong link. So THANK YOU SO MUCH ..Have been trying to make Note 7 sync for a week ..including going to Verizon stores & calling Google. I turned off the 'POWER SAVE' & bingo, everything worked immediately. Do you know if this mean there's no way to use the power save option?
    09-01-2016 09:45 PM
  11. Mary Anne Oswald's Avatar
    Found it - on your S7, go to Settings, Accounts, Google and select in the list to sync gmail (turn the slider on) and now works!
    10-12-2016 09:09 AM
  12. Mystery Buff's Avatar
    It appears that turning off Power Saving fixes the issue. Bought my S7 the end of September 2016. Immediately had sync problems in 3 Google apps: calendar, contacts, and gmail. Sometimes 2 of 3 apps would sync after 3 weeks of waiting. Especially frustrating was not being able to get appt. notifications for as long as 3 weeks after they were made and sometimes after I was supposed to be there. Didn't contact tech support but did check online. However, none of the proposed solutions fixed the problem. I slowly worked my way thru every "Accounts" setting on the phone for each of the 3 Applications. When I worked my way thru each of the phone "Accounts" settings, I found that the second I switched power saving off, all Google apps immediately synchronized. Since that time, new appts, contacts, and mail additions and changes immediately appear in the corresponding apps on my desktop and tablet. (I was only using the medium, not high, Power Saving level.)

    Can't believe that this is a problem that Samsung isn't taking more seriously.
    11-15-2016 07:57 AM
  13. Jeffrey Leal's Avatar
    In the battery settings if you click on the "power save mode" it will allow you to deselect "restrict background data". This fixed the problem and allowed me to remain on "power saving mode"
    03-06-2017 09:31 AM
  14. Halee Stater's Avatar
    this is not working with the new software update, any ideas on a fix top use power saving mode?
    06-27-2017 02:55 PM
  15. souper80's Avatar
    I still have the same problem. Unable to auto sync (although switched on in account setting for Gemail, and disabled power saving for Gmail).

    When clear cache and re-log in Gmail, can sync up to latest. However, after that, still can not auto-sync. Can not always clear cache to refresh email :-( anyone still get same problem, and any idea about solution?
    07-04-2017 09:10 PM
  16. casakama's Avatar
    Why cannot my gmail from my wife and a few other people (all gmail). Yet if I give them my alternate gmail account it all comes in. Other email always comes in. Puzzled I am!!!
    10-26-2017 05:11 PM
  17. Brett Okeefe's Avatar
    Wjen I go into settings/accounts O see noth email accounts have "sync dissabled" but no option to enable them
    04-22-2018 03:31 PM

Similar Threads

  1. Chinese characters when I unlock galaxy s5?
    By AC Question in forum Ask a Question
    Replies: 15
    Last Post: 07-12-2016, 01:57 AM
  2. Replies: 1
    Last Post: 03-11-2016, 02:30 PM
  3. Bricked my Nexus 9
    By dirtyjudo in forum Android 7.0 Nougat
    Replies: 3
    Last Post: 03-11-2016, 09:36 AM
  4. Replies: 0
    Last Post: 03-10-2016, 03:58 PM
  5. How to switch sim from Samsung s7 to IPhone?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 03-10-2016, 03:50 PM
LINK TO POST COPIED TO CLIPBOARD