1. AC Question's Avatar
    The WiFi is runing great on all devices, including iPhones, Samsungs S6s, laptops, music devices etc. But on S7 will take 15 sec or more to load a web page. Also, some apps are very slow. Again, I updated the dlink router firmware, the wireless is supper strong in the house, I played with the router setup, went back to Best Buy they cleared the cache, basically did everything. Anyone has this type of issue? Additionally the battery is acting strange. My son is not very happy with this phone. Any help it is much appreciated!
    03-18-2016 01:34 PM
  2. srkmagnus's Avatar
    Take a look at this thread: http://forums.androidcentral.com/sho...d.php?t=654181

    It seems like it could be the router band, or possible interference from Bluetooth I'd you have it enabled.
    03-18-2016 02:26 PM

Similar Threads

  1. S7 Edge AT&T Software Update (3/18/16)
    By pgood4 in forum Samsung Galaxy S7 edge
    Replies: 32
    Last Post: 04-26-2016, 02:04 PM
  2. How do I stop downloading on my Samsung Galaxy 3?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 03-18-2016, 02:33 PM
  3. My earphones aren't working on my Galaxy Tab A?
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 03-18-2016, 02:30 PM
  4. Why does my mail delete from the server when I delete it from the tablet?
    By AC Question in forum General Help and How To
    Replies: 1
    Last Post: 03-18-2016, 01:27 PM
  5. Replies: 0
    Last Post: 03-18-2016, 01:01 PM
LINK TO POST COPIED TO CLIPBOARD