1. AC Question's Avatar
    Hello. For some weeks I've been trying to fix the problem that my Hudl 2's Google Play Services will not update, causing me to be unable to install any apps from Google Play or update any apps already installed.

    There have been a few pages i've found online that have offered some help - clearing the caches from the app, etc or a factory reset. These have not worked.

    I decided to try to install the Google Play Services APK manually. The instructions say the following:

    "To figure out the right version of Google Play services for your Android device, go to Settings -> Apps -> Google Play services, and look at the last 3 numbers in the parentheses. You'll see something like -XYZ where:

    * X defines Android version:

    0 for Android <5.0
    2 for Android 5.0 and 5.1 starting with Play Services v8
    4 for Android 5.0 and 5.1 before Play Services v8, Android >= 6.0 after
    7 for Android 5.0
    8 for Android TV
    * Y defines CPU architecture:

    1 for armeabi
    3 for armeabi-v7a
    4 for arm64-v8a
    7 for x86
    * Z defines DPI:

    0 for universal
    2 for 160
    4 for 240
    6 for 320
    8 for 480"

    Now my current version number is -480. I cannot find anywhere a definition for what CPU architecture is version "8". I tried downloading the APK for 7, x86 but my tablet could not read the file. Is "8" x86-64 bit and if so, where do I get the correct APK.

    Or, is there a better solution to this problem?
    03-21-2016 06:40 AM
  2. Leng64's Avatar
    You will need Google play services version 8.7.03 (2645110-280) this is the hudl 2 x86 64 bit version.
    04-23-2016 09:06 AM
  3. Wena39's Avatar
    Just tried this myself after having same problem and it's now fixed. Thanks
    05-02-2016 05:06 PM
  4. biddlej1306's Avatar
    Brilliant! This worked perfectly. I had googled the issue and had been clearing the Google Play Services cache as suggested elsewhere, but it didn't work. After installing this version of Google Play Services, I then cleared the cache and then those wretched "Google Play Services has stopped working" messages finally disappeared.
    THANK YOU!!
    02-08-2017 02:46 PM

Similar Threads

  1. Replies: 2
    Last Post: 10-19-2016, 08:38 PM
  2. [FIX] [SOLVED!] Play Store No Connection Error Fix!
    By Nezzaros in forum Ask a Question
    Replies: 1
    Last Post: 07-21-2016, 02:02 AM
  3. Software update disclaimer
    By cdangers in forum Samsung Galaxy Note Edge
    Replies: 1
    Last Post: 03-21-2016, 01:09 PM
  4. Replies: 0
    Last Post: 03-21-2016, 06:34 AM
  5. My Galaxy View 18.4 inch is stuck in Odin Mode Help!!
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 03-21-2016, 05:10 AM
LINK TO POST COPIED TO CLIPBOARD