1. owengerig's Avatar
    I have a nvidia shield tablet running Android 6.
    My main question here is how to read the sd card without a device?

    The reason behind my question is that every time i put the sd card in the device it will work (can view & edit files on it) for a short time then it will freeze, crash and reboot the whole device.
    I really just need to get my titanium backup files from it so i can restore my device.

    I have of course tried to plug it into my windows laptop
    but windows wants to format the drive (doesnt understand the file system)
    but i could easily spin up a linux box if that would help, or i have access to osx as well

    I also tried using and otg cable and plugging it into another android device (running cyanogenmod) but it did not show any files, not sure usb host really works on that device
    03-21-2016 09:42 AM
  2. Golfdriver97's Avatar
    Welcome to the forums. If you can take the card out of the device when it's off, you can insert it into your PC, and try to pull the files off and then connect the tablet to the same PC.

    If the card is damaged, there may not be much you can do.
    03-21-2016 09:49 AM
  3. LeoRex's Avatar
    Judging by what you are saying, I suspect that the card may be corrupted. Windows might be trying to read in the FAT and get the file index built and fails, so it just tosses it out and asks you to format the card. On the tablet, that index failure seems to be causing a kernel panic, which reboots the device.

    SD cards are all formatted using FAT32, which is a native filesystem to Windows... NOT Android. So if Windows looks at it and says "Nah..." that is most often a sign that the data on the card is toast. It doesn't take much on SD cards... they are far less 'hearty' than on board media, or HDs, etc. All it takes is a small portion of the media to go South and the whole card can go into the toilet.
    03-21-2016 09:54 AM
  4. owengerig's Avatar
    thanks for the greetings
    I have tried putting it into my windows laptop but it wants to format the drive.

    are you sure about the fat32 thing when the sd card was setup to be "Internal mode" LeoRex?
    03-21-2016 10:05 AM
  5. Golfdriver97's Avatar
    I'm pretty sure Leo is right about the stock Fat32 for cards. I recall most of mine being that way.
    03-21-2016 10:07 AM
  6. LeoRex's Avatar
    are you sure about the fat32 thing when the sd card was setup to be "Internal mode" LeoRex?
    Oh.... hold the phone... 'internal mode'? That changes things a bit. If it's 'portable', then the filesystem is FAT32. I just looked into this a little bit and if you selected 'internal' mode, it may have formatted the card as a native filesystem and then encrypted the data. In terms of recovery standpoint, that's bad news since that card will not be able to be read by anything once you pull it out of the phone. It's Nvidia's terminology for the new Adoptive Storage feature in Android 6.0.

    Either way, the card is most likely having issues... but since it's set to internal mode, that device is most likely the only one that will be able to read it.

    Not sure what to tell you as far as recovery options here. The core issue is that bad card. Had it been external/portable, then the Windows box would have been able to take a look at the files and you might have been able to get the data off. Internal? Can you get in there to copy files off before it reboots? Or does it reset as soon as you try to read it?
    Golfdriver97 likes this.
    03-21-2016 10:20 AM
  7. owengerig's Avatar
    not really sure the exact size of the directory but i only have a minute maybe 2 (if that) to copy before reboots.
    i didnt even think of encryption. that really sucks. ill need to research how to turn that off
    you say "native filesystem" but what would that be for android?
    lets say it wasnt encrypted could osx or linux read it?

    sucks too because like ive said it seems like some process that is checking the disk upon insertion, it was crashes the device
    if i could get in and kill the process in time maybe that would do it

    I also just tried booting into twrp recovery mode, but i cannot mount or view the sdcard from there. though that was always the case (even before this problem started)
    03-21-2016 11:04 AM

Similar Threads

  1. Opening S Note files(.snb) on Huawei G8
    By sajjad zarrinmalek in forum Huawei G8
    Replies: 4
    Last Post: 11-09-2016, 07:55 PM
  2. Hello Folks, SD Card question
    By carlarcher in forum New to the Forums? Introduce Yourself Here!
    Replies: 14
    Last Post: 03-28-2016, 12:04 PM
  3. Replies: 6
    Last Post: 03-24-2016, 07:37 AM
  4. Where are my photos on my phone?
    By AC Question in forum General Help and How To
    Replies: 3
    Last Post: 03-21-2016, 12:29 PM
  5. How can I unlock frp lock without otg .help please?
    By apollo cristian in forum Samsung Galaxy Note 5
    Replies: 1
    Last Post: 03-21-2016, 09:36 AM