1. AC Question's Avatar
    A few weeks ago, I dropped my phone in the toilet, but was able to get it out rather quickly. The phone was only halfway submerged. I immediately disassembled my phone all the way down to the motherboard and used a hair dryer. Everything else still works perfectly when I turned it back on...EXCEPT for the speakers. At first, I thought I damaged the loudspeaker that is attached to the middle frame, so I bought a new middle frame with a new loudspeaker attached to it. I installed it to my phone and it still has the same problem. The weird thing is, I could use the headphone jack just fine. I could actually listen to music as long as I plug my headphones it, but not on the external speakers. I checked for corrosion on the motherboard but did not find any. I even tried to clean the motherboard with 99% alcohol solution but the speakers are still not working (it just gives cracking/static sound). What do you think could be wrong with it? Could it be a circuit problem? I've been on the Internet scouring through any solution to this but I couldn't find any. I hope anyone from here can help me. I just had my phone for only 3 months. Thank you for all of your advice.
    03-25-2016 07:15 PM
  2. belodion's Avatar
    Water damage tends to be progressive. Did you use alcohol immediately to remove the water before disassembling and drying?

    [GUIDE] Oh, no! My Phone got Wet!
    http://forums.androidcentral.com/sho...d.php?t=477140
    03-26-2016 07:41 AM

Similar Threads

  1. Replies: 0
    Last Post: 03-25-2016, 06:56 PM
  2. How to get into my phone when I forget pass code pattern?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 03-25-2016, 06:40 PM
  3. Replies: 0
    Last Post: 03-25-2016, 06:38 PM
  4. Replies: 0
    Last Post: 03-25-2016, 06:38 PM
  5. Unblock number? Allow to receive messages on S2???
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 03-25-2016, 06:33 PM
LINK TO POST COPIED TO CLIPBOARD