1. anon(9893460)'s Avatar
    Hello all! I have an lg g3 vs985 on metropcs. I recently upgraded to cm13. Since I'm learning I did brick a couple times. One time I had to go back to stock. But everything has been fine lately until I realized I wasn't getting any texts. Then I attempted to text myself and nothing. When I send a text it shows it as sent it weird. I can't find anything online anywhere. Things I have tried *#*#4636#*#* nothing everything seemed fine. I played with preferable networks cause in order to get my p uh one to work after cm13 that's what I had to do. I have booted in recovery and wiped cache and Dalvik more then once. I cleared data for messaging and there was others I just can't remember at the moment. I also tried 3rd party apps like go SMS pro. None have worked. Right now I'm using one of those flaky apps that give you a new number and allow you to call and text with data. but I'm worried with all the texts I may have missed from work and and daughter. I haven't tried a factory reset yet I really don't want to... I'm really tired of doing that after everything has been set up. Any advice would be helpful. I'm ready to snap my phone in half it's so aggravating. I read someone in similar situation not the same though had to go back to stock. I really don't want that. OK I just realized when I make a phone call I get a flood of texts but I still can't text.

    04-19-2016 09:01 PM
  2. jeff275's Avatar
    I had a similar problem when I switched to StraightTalk (which I have since had to drop due to all the problems) and initially I had to use a different SMS app (I think it was Textra that I used) but I don't think that allowed me to get picture messages. I finally got it working by using different APN settings than the ones StraightTalk gave me. It was a lot of changing APN settings and rebooting but that's what finally worked for me. I found the information by seaching for StraightTalk APN settings so something similar may help you.
    04-20-2016 10:33 AM
  3. anon(9893460)'s Avatar
    I have tried all of that unfortunately

    04-20-2016 12:19 PM
  4. anon(9893460)'s Avatar
    Well after all the things I tried the most simple worked! I simply called metropcs and asked them to perform a network refresh. After I got off the phone I reboot and now all seems to be working. But only time will tell. Also I think I'm going to stay away from any new cm13 nightlys. Thank you for your advice!

    04-20-2016 02:34 PM

Similar Threads

  1. Why can't I send texts anymore after updating to Marshmallow?
    By AC Question in forum Ask a Question
    Replies: 3
    Last Post: 05-10-2016, 07:04 PM
  2. Android won't send SMS to any new contact/number
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 04-19-2016, 07:34 PM
  3. HTC one m7 without ROM and i can't isntall new.
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 04-19-2016, 06:40 PM
  4. Replies: 0
    Last Post: 04-19-2016, 06:13 PM
  5. Replies: 0
    Last Post: 04-19-2016, 06:12 PM