1. AC Question's Avatar
    I have an android app with haveing several permissions listed bellow:
    <uses-permission android:name="android.permission.INTERNET" />
    <uses-permission android:name="android.permission.ACCESS_FINE_LOCATION" /><uses-permission android:name="android.permission.ACCESS_COARSE_LOCATION" />
    <uses-permission android:name="android.permission.ACCESS_NETWORK_STATE" />
    <uses-permission android:name="android.permission.RECORD_AUDIO" />
    <uses-permission android:name="android.permission.WRITE_EXTERNAL_STORAGE" />
    <uses-permission android:name="android.permission.NFC" />
    android:required="false" />

    android:targetSdkVersion="22" />

    The app continuously gets the sensors information. I have tested in OnePlus 1, Nexus 5 with same android version (5.1.1). These are working fine. But in some other device with same and bellow SDK version, the app is installing properly but showing error while running. The error message is like "Unfortunately the app has been stopped".

    I have no clue why this is happening. Please help to fix the android crashing problem.

    Thanks in advance.
    04-25-2016 07:05 AM
  2. domdo's Avatar
    this is your app? i think that the problem is NFC.
    use minSdkVersion="10" instead of minSdkVersion="7"
    04-25-2016 08:11 AM
  3. Mahedi Kaysar's Avatar
    Thanks for your reply. I have tried. but same error.
    04-25-2016 08:56 AM
  4. Mahedi Kaysar's Avatar
    I have solved the problem. The problem was v4 and v7 dependency. It was showing runtime error:
    "Error inflating class android.support.v7.widget.Toolbar"
    04-25-2016 12:35 PM

Similar Threads

  1. Bandar: The Jumper (Free android Game)
    By Mohamed Ezzat Mohamed Awadalla in forum Android Games
    Replies: 1
    Last Post: 05-11-2016, 08:18 AM
  2. Replies: 3
    Last Post: 04-26-2016, 06:16 PM
  3. Replies: 1
    Last Post: 04-25-2016, 07:48 AM
  4. Replies: 1
    Last Post: 04-25-2016, 06:59 AM