1. AC Question's Avatar
    I am trying to install app from google play store and it will not download, it says it is downlaoding but after 14 hours i don't think it is working. I have tried other apps thinking it was a problem with that app but nothing works. I have deleted the cache in my phone and google play store and restarted my phone. Nothing has worked
    05-02-2016 03:25 PM
  2. Tim1954's Avatar
    Do you have an ad blocker installed in device? Is there enough room in phone storage? Have you force stopped the play store app?
    05-03-2016 04:45 AM

Similar Threads

  1. Galaxy S7 Lock Screen Sucks!
    By webaber in forum Samsung Galaxy S7
    Replies: 5
    Last Post: 06-05-2017, 02:37 PM
  2. $$ for someone that can solve this technical issue on a Huawei Union w/ Android v5.1
    By PeteMartin1 in forum Software Development and Hacking
    Replies: 5
    Last Post: 05-04-2016, 11:49 PM
  3. GO SMS PRO 2016 Sound Notification on Galaxy s6 edge +
    By mswinkle in forum Samsung Galaxy S6 edge+
    Replies: 1
    Last Post: 05-02-2016, 11:04 PM
  4. why does my phone keep beeping even without anything running
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 05-02-2016, 03:19 PM
  5. Can't run videos in the background anymore on Samsung Galaxy S6
    By ThatOneBacon in forum Ask a Question
    Replies: 0
    Last Post: 05-02-2016, 03:01 PM