1. AC Question's Avatar
    My htc one m8 is stuck on the clockworkmod recovery screen,
    i just have no idea what i am supposed to do to get my phone back working again,
    i have spen 3 days trawling through the internet and is till cant come up with how to get my phone back to stock,
    i have tried most things but its still not working
    05-16-2016 08:33 AM
  2. Golfdriver97's Avatar
    Welcome to the forums. If you have a Windows PC, you should be able to reflash the stock files. You can go here for them: ROM Downloads for your HTC smartphone - Support | HTC United States

    I did an RUU not too long ago. It wasn't that hard. Just open the downloaded file, and it's nearly self automated.
    05-16-2016 09:20 AM
  3. Liam_89's Avatar
    Thanks for the reply,
    I can't connect the phone to my pc as its not being recognised, even with htc sync installed,
    I have tried putting roms onto micro sd card and installing from there but nothing will work,
    Basically the phone won't boot into the operating system as I believe there isn't one there,
    The only thing that is on the phone is clockworkmod recovery,
    It will startup into the menu with the fastboot options etc... And it says unlocked
    I just don't know what to do
    I have no backup and no roms will work
    I have tried various different downloads and still nothing
    I just can't get it to boot up at all
    It starts up to a white screen with HTC logo and red developer writing at the bottom but that's it
    Any help would be greatly appreciated as I really am stuck and don't know what I can do

    PS: I did not do any of this as I have no clue what I am dong, I purchased the phone like this with the hope that It would be as easy as just reinstalling android, but that's not the case
    I am an iPhone convert and this is supposed to be my first android device,
    Wouk be great to get it working as I currently have no phone and I'm new to android
    05-16-2016 10:28 AM
  4. Golfdriver97's Avatar
    Can you reboot into the bootloader?
    05-16-2016 02:00 PM
  5. Liam_89's Avatar
    Yes I can get into the bootloader,
    If you mean the white screen with the options on and the device id numbers etc...
    To fastboot etc,
    And can boot to clockwork mod,
    I have tried using on my pc but it's not working
    I have tried to instal stock roms from my micro sd and still nothing
    I jaunts don't know what to do it's like nothing works
    05-16-2016 02:43 PM
  6. Golfdriver97's Avatar
    When in the bootloader you can execute the file that you can download from HTC.
    05-16-2016 03:33 PM
  7. Liam_89's Avatar
    Yeah I can execute the file but it's saying,
    Zip ( bad ) installation aborted
    Says it for every one i try
    05-16-2016 03:44 PM
  8. Golfdriver97's Avatar
    05-16-2016 04:02 PM
  9. Liam_89's Avatar
    I bought the phone on eBay in this condition
    And the carrier is unknown
    But looking at the radio id number then I'm assuming it's Vodafone uk
    Which is the network I have my sim contract with,
    I have tried the rru for the Vodafone Id number and it's still not working
    I have tried to instal custom roms to try and get it going and this still won't work
    Just seems like nothing will
    Thanks again for taking the time to help me
    05-16-2016 04:21 PM
  10. Golfdriver97's Avatar
    I'm curious if a backup can be pushed via fastboot commands. I'm asking around now.
    05-16-2016 04:38 PM
  11. Aquila's Avatar
    A backup cannot be installed via fastboot directly, but a clean install can be installed via fastboot such as fastboot flashall that we use for factory images. However this would not be for a typical ROM install, which would use a .zip, it'd be for an unpacked factory image.

    It sorta sounds like USB debugging may not be enabled - but it also sounds like the drivers aren't installed properly for the PC, because the PC should see something - even if it doesn't realize it's a phone that it can send commands to. In order to be able to return the phone to stock, it doesn't need a current OS - but it does need USB debugging enabled, S-OFF and on the M8 you can only do these commands through a USB 2.0 port.

    But once you have the RUU you need, the files should be there - but you should expect to see a few "failed" messages.

    Basically you'd use:

    adb reboot bootloader
    fastboot oem rebootRUU
    fastboot flash zip insert location of your RUU.zip

    Then you get a FAILED message and it'll reboot

    and after it reboots enter:

    fastboot flash zip insert location of your RUU.zip
    fastboot reboot

    Disclaimer: I don't have an M8 to test this on. And all the usual stuff people usually say when they warn you not to blow up your device.
    05-16-2016 05:08 PM
  12. Liam_89's Avatar
    Thanks so much for the above info,
    My pc does recognise the phone and I can see it in the device manager,
    S is also off
    I just can't do anything with it
    05-16-2016 05:14 PM
  13. Aquila's Avatar
    Long shot question, but have you installed the latest SDK and set up your directories to use adb?
    05-16-2016 11:54 PM
  14. Liam_89's Avatar
    Thanks for the reply assassin but I have no idea what that means
    As mentioned I am totally new to android
    And just wish I could get up and running so I can see what it's like thanks
    05-17-2016 02:18 AM
  15. Aquila's Avatar
    05-17-2016 09:43 AM
  16. Liam_89's Avatar
    Thanks assassin but without sounding stupid
    I have absolutely no idea what that programme is for
    05-17-2016 11:59 AM
  17. Aquila's Avatar
    Thanks assassin but without sounding stupid
    I have absolutely no idea what that programme is for
    The instructions for downloading and installing the SDK are there. Basically what we want out of it is the ability to access your phone with a command line terminal to use the fastboot interface and push files to it via USB. I'm checking with some friends to see if we have a good guide or go to location for detailed instructions. For now, this video seems pretty decent:

    05-17-2016 03:27 PM

Similar Threads

  1. HTC 10 Camera focus
    By Tohena in forum HTC 10
    Replies: 9
    Last Post: 05-17-2016, 07:05 AM
  2. Replies: 2
    Last Post: 05-16-2016, 10:06 AM
  3. my phone is stuck on logo
    By Rahma Hesham in forum Ask a Question
    Replies: 1
    Last Post: 05-16-2016, 09:45 AM
  4. Cant download facebook on phone
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 05-16-2016, 09:21 AM
  5. Gallary app wont open on my note 5.
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 05-16-2016, 08:18 AM