1. AC Question's Avatar
    My brother gave me his old phone that he no longer uses, he went to China to study, and his phone broke! He went to a place to fix it, but his phone got reset and he no longer has Google Play Store. Long story short, I have his phone now, and it doesn't have Google Play. I tried downloading Google Play from apkmirror, but every time I tried opening it, it keeps crashing! Help please
    06-05-2016 05:46 AM
  2. the tall guy's Avatar
    Hi, what device is it that you have? I would have imagined that Google Play should have been on the phone. Have you considered performing a factory reset on the device to see if that helps? If you do, back up all your data as it'll be deleted.
    06-06-2016 02:41 AM
  3. Kenoby's Avatar
    I'm using a Galaxy Note 1 that my brother used to own. And I tried factory resetting
    06-06-2016 08:49 PM
  4. the tall guy's Avatar
    Hi, thanks for joining and welcome to AC is the phone rooted ? I would recommend you take the phone back to where it was repaired and see if they can help as by the sounds of it, they broke it further.
    06-07-2016 06:27 AM
  5. Kenoby's Avatar
    That's gonna be a problem, since that's in China
    06-07-2016 10:43 PM
  6. the tall guy's Avatar
    Yeah that's a bit of a walk for a phone that's 5 years old.

    As the phone is really old, it might just be passing its expiry date. Do you have anyone local who can have a look at the phone and perhaps fix it?
    06-08-2016 02:09 AM
  7. Kenoby's Avatar
    I don't think so. I'm most likely just gonna buy a new one since this one is so old, but having to phones can be useful
    06-08-2016 08:50 PM

Similar Threads

  1. Replies: 1
    Last Post: 06-06-2016, 07:56 AM
  2. Replies: 1
    Last Post: 06-06-2016, 07:50 AM
  3. Google Play
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-06-2016, 02:37 AM
  4. Replies: 0
    Last Post: 06-04-2016, 10:41 PM
  5. Replies: 2
    Last Post: 06-04-2016, 10:06 PM