1. AC Question's Avatar
    Okay so a couple of days ago i tried updating my lenovo s60 (non-removable battery) to android lollipop, what happened is , the update was fully downloaded and the phone rebooted, the update was getting installed , after a while it got stuck on 75%, i waited upto 5-6 hours and it was still the same , so i had no option but to shut down the phone manually.
    When i tried to boot it up again , it wouldn't go past the lenovo powered by android screen, this has happened to me before but in the past occurances , it would go to the second screen after the lenovo powered by android, the problem with it getting stuck on the first screen is that i cant get my phone to recovery mode, the recovery mode is where i fixed my phone when this happened before so now i have no idea on what to do since i cant get my phone into recovery and my pc doesn't detect it.
    So i gave it to 2 mobile service centers hoping that they would fix my phone and they couldn't fix it too, that leaves me thinking that i can't do anything to fix my phone.
    i just decided to leave a reply here so that someone could do something and help me fix my phone. i know its not hard bricked since it still turns on and gets stuck only on the first screen. but i really dont know what to do.Thank you all who take the time to read this through.
    P.S: My phone isn't rooted.
    06-11-2016 09:36 AM

Similar Threads

  1. Kind of original foil on LG v10?
    By Andrzej Wielki in forum LG V10
    Replies: 5
    Last Post: 06-18-2016, 12:13 PM
  2. Why wont my phone turn on?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-11-2016, 10:35 AM
  3. Replies: 0
    Last Post: 06-11-2016, 09:27 AM
  4. Replies: 0
    Last Post: 06-11-2016, 09:25 AM
  5. My screen is cracked a little bit, will it harm me?
    By AC Question in forum Ask a Question
    Replies: 5
    Last Post: 06-11-2016, 09:15 AM