1. AC Question's Avatar
    Hi, my 128G Micro SD card worked perfectly before I took it out, transferred files on my MacBook Pro. After that, when I put it back on note4, it says damaged card. Now the card shows "read only", can't even format or erase with disk utility because the options are deemed.
    I also tried on a Windows computer, format is "not permitted".
    I tried the commands in terminal as well, same, "can't erase".
    What should I do now?
    06-18-2016 10:22 AM
  2. dingdingdang's Avatar
    Oh, I can't write or delete files on it
    06-18-2016 10:26 AM
  3. dingdingdang's Avatar
    Micro sd card, took off to transfer file on MacBook, then became read only, won't mount card says corrupt card, but can see card on both Mac and PC. Can't format, options for erase in disk utility are greyed out. Can't write or delete files. Command lines in Terminal didn't work either.
    06-20-2016 10:09 AM

Similar Threads

  1. Huawei / EMUI 4.1 and SD card management
    By qmatteoq in forum Huawei P9 & P9 Plus
    Replies: 4
    Last Post: 08-27-2016, 03:49 PM
  2. Why won't my phone turn on?
    By themanwow in forum LG G3
    Replies: 2
    Last Post: 06-20-2016, 05:39 PM
  3. Problems after storing apps in sd card
    By nsandi in forum Samsung Galaxy Note 4
    Replies: 3
    Last Post: 06-19-2016, 09:58 PM
  4. Link2d mount error deletes all of my homescreen folders.
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 06-18-2016, 10:14 AM
  5. Should i remove my sd card befor i do a factory reset?
    By TraciPage in forum Ask a Question
    Replies: 3
    Last Post: 06-18-2016, 02:07 AM