07-10-2016 09:35 AM
27 12
tools Reply
  1. AC Question's Avatar
    We have two Samsung Galaxy SII phones. We use Sprint. Both started having problems with the battery draining extremely fast at the same time. When I look under Settings: Applications: running: It shows Google play services, com.samsumg.internal, voicemail, and some other Sprint services gaining time at a high rate. The battery is draining so fast, it is getting hot.
    Is there a way to reset or fix the phone?
    06-26-2016 10:03 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Charge up to 100%, then let it drain to 20-30% with normal usage, without charging in between. Then show us:

    1. The main Settings>Battery screen.
    2. The fullscreen battery graph screen (which shows Awake time and Cell Signal Strength).
    3. The Screen category (to see total Screen On time).
    4. The Cell Standby category, if present (to see Time Without Signal).

    06-26-2016 11:36 PM
  3. Max2598's Avatar
    I'm not the original poster, but I had the same problem, starting a few days ago. The battery usually lasted a whole day without problems. Now, it barely last half a day.
    I tried to uninstall or disable a bunch of apps, disable location services and I restricted background data. Nothing changes (or only get worse).
    My device is a Samsung tablet GT-P6800.
    Here are the screenshots:
    The battery was at 100% when I unplugged the device, so 77% of the battery was used in 4 hours!

    Any tips on how to fix this problem would be very welcomed.
    Attached Thumbnails Battery draining fast - started on 6/23/2016-screenshot_2016-07-02-13-25-17.png   Battery draining fast - started on 6/23/2016-screenshot_2016-07-02-13-25-41.png   Battery draining fast - started on 6/23/2016-screenshot_2016-07-02-13-25-57.png  
    07-02-2016 10:12 PM
  4. B. Diddy's Avatar
    Welcome to Android Central! The Google Services drain issue can be difficult to troubleshoot, because other apps can utilize Google Services as well. So the drain might actually be due to some other app, not Google Services itself. Unfortunately, this may require you to uninstall apps one by one until the problem goes away.
    07-02-2016 11:38 PM
  5. RobinC1's Avatar
    I had the same issue recently! After completely shutting off my phone and letting it sit for a couple of hours it seems to have returned to its normal functionality. I hope this will work for everyone else.
    07-03-2016 12:02 AM
  6. Mattsta1's Avatar
    I've had a similar problem. For the last 5-7 days, Google services has been eating my battery life at a ridiculous rate. Sync is off, location off, nfc off. Battery life on my s7 was great until this week. I'm so sad 😟
    07-03-2016 01:55 AM
  7. robertrj's Avatar
    I'm experiencing the same problem... Have even created a topic here. My phone is a Samsung Galaxy Ace 2, and no matter what I do Google Play Services is taking close to 85% of battery. I noticed also that checking the battery details, phone is almost all the time awake.

    I believe there is no much that can be done, seems like a problem with te Google Play Services. But, the strange is that I observe this only on my phone (running an older Android version), I also have a Samsung tablet that is very recent, and even though the same Google Play Services version, battery consumption is insignificant.
    07-03-2016 09:14 AM
  8. Max2598's Avatar
    Thanks for your answers.
    I tried Airplane mode. I activated the airplane mode just a couple of minutes after turning on the device (which was completely turned off while the battery was charging): the battery consumption rate was very low, back to normal (but of course, I couldn't do much with it). I disabled the airplane mode, and the battery usage rate went up again very quickly, AND stayed up even when I turned the airplane mode on again.

    Following an advice found on another forum, I installed a wakelock detector to try and detect which app maintain a wakelock: it was first Google+, so I disabled it, then Chrome, so I uninstall it. It's now showing Gmail...
    I won't have much of a phone or tablet left...

    Considering this is happening to a number of us, and especially for older devices, and not new ones, I think it's more likely that the cause is not a specific app, but a bug in a recent update of google services, or a problem of retro-compatibility with older versions of Android.
    07-03-2016 12:29 PM
  9. jsigmo's Avatar
    I'm having the same problem on my Samsung Galaxy SII. It started a few days ago.

    In one of the other threads on here about this issue, someone stated that Google Services, which Google auto-updates regardless of your update settings, has a bug in the newest version. I cannot verify this myself, but this seems to be happening to a lot of people all of a sudden, and people have tried everything up to and including doing a factory reset and NOT installing any of their apps. Still, Google Services is draining their batteries.

    For me, Google services is causing almost all of the battery usage on my phone.

    Google Services - 94%
    Android OS - 2%
    cell standby - 2%
    screen - 2%.

    In addition, I keep getting crashes of Google Services. I get messages saying that it's not responding, and wanting me to close or wait. Sometimes I get the option to report, etc.

    I deleted Google Services and then reloaded it by trying G-Mail, which won't work without it, and then using the option it presented for "getting" it.

    But I'm sure that just downloaded the latest version, which, according to some, has a bug causing this issue.

    If this is the case, I sure hope Google rolls out a patched version soon! My phone's battery dies in a couple of hours from full charge now, and stays quite warm to the touch at all times.

    07-03-2016 04:50 PM
  10. robertrj's Avatar
    I tried the airplane mode too. Observed the same issue... Recently got some of those crashes too. :-

    I don't know, isn't there any way w can contact Google about it? I'm noticing more and more people facing this too, recently talked to my mother and she said her phone is also draining battery so fast, possibly because of the same Google Play Services update. By this time, I would expect that Google could at least let people know if they are working on that.

    Personally, I still think that is some sort of idea to make older phones running older Android versions obsolete and impossible to use. I know there are many new phones now, and new Android versions have neat features... But some of us don't want (or can't) afford to buy a new phone every year. I know this is how most people like, but there are still users that take care of their phones and make them last. My phone has more than 3 years, has been working perfectly fine until this update. This was one of the reasons I have chosen an Android phone instead of a iPhone, because I know how that thing gets obsolete so fast...
    07-03-2016 06:02 PM
  11. B. Diddy's Avatar
    I don't know, isn't there any way w can contact Google about it?
    Go to Settings>About Phone and see if there is a "Send feedback about this device" option. Or go to Settings>Apps​, tap Menu>Help & Feedback, then tap Send Feedback.
    07-03-2016 06:20 PM
  12. jsigmo's Avatar
    I tried the airplane mode too. Observed the same issue... Recently got some of those crashes too. :-

    I don't know, isn't there any way w can contact Google about it? I'm noticing more and more people facing this too, recently talked to my mother and she said her phone is also draining battery so fast, possibly because of the same Google Play Services update. By this time, I would expect that Google could at least let people know if they are working on that.

    Personally, I still think that is some sort of idea to make older phones running older Android versions obsolete and impossible to use. I know there are many new phones now, and new Android versions have neat features... But some of us don't want (or can't) afford to buy a new phone every year. I know this is how most people like, but there are still users that take care of their phones and make them last. My phone has more than 3 years, has been working perfectly fine until this update. This was one of the reasons I have chosen an Android phone instead of a iPhone, because I know how that thing gets obsolete so fast...
    I agree. My wife and I have had these phones for a long time, and have kept them in good shape. They're now "off contract" and we've been eligible for the "free" upgrade to new phones for a couple of years. "Free", my behind!

    Off contract, we're paying more than $100 less per month than when the phones were new and under contract. The phones (Galaxy Skyrocket S2) do everything I need a phone to do.

    If Google obsoletes these phones on purpose, that will be a good reason to switch back to a dumb phone for me. I don't need to have a phone that surfs the net, texts, etc. It's nice, but not necessary. But one thing that is necessary is that the phone's battery last at least 24 hours when "idle". Preferably more like 48.

    We both have several tablet devices, and are almost always within WiFi range when we want to surf, update email, etc. So these inexpensive tablets have somewhat obsoleted the web functions of our phones.

    I can't see signing up to pay $2400 over the next couple of years to pay for two new phones. Especially if it's made necessary on purpose.

    I suspect it's just a bug, though. I don't think Google would "crap in their own mess kit" like this on purpose.

    Time will tell. Meanwhile, the fix needs to happen fast. This really is very annoying to say the least. Assuming it IS a bug in Google Play Services (or Google Services), they've killed millions of phones right as we're having a long holiday weekend here in the US, when people are traveling and can least afford to have their phone batteries being drained rapidly.
    07-03-2016 08:25 PM
  13. jsigmo's Avatar
    Go to Settings>About Phone and see if there is a "Send feedback about this device" option. Or go to Settings>Apps​, tap Menu>Help & Feedback, then tap Send Feedback.
    None of those options appear on my phone.

    Further, I find no way to rate the app or leave feedback, either, since it doesn't seem to appear in the Play Store!

    However, browsing on my PC, I DO find it at:


    But you can't rate it unless you download it, etc.

    But an interesting tidbit on the site there is this:

    June 30, 2016"

    So that corresponds precisely with when my phone started having this issue. Something of a smoking gun, it seems.

    Edit to add:

    I logged into my google account, and it knows all of the apps I have, including this one. So I should be able to "write a review" for it. However, as I'm trying to do this, the page locks up. Maybe they've disabled this for now because they are already aware that there's a bug.

    That would be fine. That would mean that they're aware of the problem and are working on it.

    We can only hope!

    Edit once again....

    It appears that to leave a review, I must sign up for Google + whatever that is! No Thanks!
    07-03-2016 08:27 PM
  14. quakelife911's Avatar
    Same problem. Did a factory reset and only installed Google Play Services and it still turns my phone into trash. So we know it is NOT because of low memory or because of another application or because of my battery or sim card because it only starts happening when Google Play Services is installed. I also tryed reinstalling and that didn't do anything. I can uninstall it but without it some stuff does not work like the market. What I have gotten so far is with Google Play Services installed my phone gets way too hot and runs really slow but I have to have it on my phone for some stuff to work so only thing left to do is just keep emailing google until they fix it. I also tryed turning phone on and off changing battery modes and changing everything on the phone as in turning off location services etc
    07-03-2016 11:17 PM
  15. jsigmo's Avatar
    If we could revert to a previous version of google play services, then things would be OK. But it auto updates itself to this new, buggy version.

    Meanwhile, my phone is pretty useless.

    Tabbed in.
    07-04-2016 03:14 PM
  16. robertrj's Avatar
    Just a funny thing I observed now. Starting today I noticed at the battery screen that the Android System is using a lot too. It used to stay with very low usage (close to 2%), but now it is like it is sharing the usage with Google Play Services.

    Battery draining fast - started on 6/23/2016-sc20160704-165426.png

    Not sure if it means something...
    07-04-2016 04:02 PM
  17. Max2598's Avatar
    Thanks for sharing your experience. I was about to do a factory reset, but seeing how it didn't work for you, I won't.
    I just hope they will fix this issue really soon.
    I had already made a review on Google Play services in the app store mentioning the problem.
    07-04-2016 08:20 PM
  18. jsigmo's Avatar
    Now here's a strange twist:

    My wife has the identical phone to mine. We got them at the same time, same day, same store, etc. They're both Samsung Galaxy Skyrocket S2s.

    Mine started this problem a few days ago. Hers has not had the problem at all.

    I checked on her phone, and she had a newer version of the operating system. Mine was Android 4.0.4, and hers was 4.1.2. Hers had been acting really slow a while back, and we did a factory reset, removed a lot of wasteful apps, and ended up updating hers to the latest OS.

    That fixed her problems.

    That newer OS is a bit different in look and feel than the one I've been running. I never updated mine because I was having no problems. Was having no problems.

    Her phone also had a different version of Google Play Services. From the revision number, it seemed like it was older than what I had (seemingly lower revision number).

    So I decided to update my phone to the latest OS that is available. I did it just an hour ago or so using Samsung Keis. First I backed everything up with Kies, and then let it do the firmware update. So now my phone has Android 4.1.2 just like her phone has for a while. It'll take a while for me to get things set back up the way I want, but everything seems to still be there.

    Anyhow, now mine came with what may be the same (seemingly lower numbered) version of Google Play Services as hers has. I can't be sure until I can look at her phone again, but it looks familiar. So I figured everything might be OK.

    But alas. Right away, it started crashing ("Google Play Services has stopped responding, wait, stop?"). And it seemed to be sucking down the battery again. Oh Joy!

    Also, on my phone, with the older OS and with this newer OS, when you look at Google Play Services in what is NOW called "Application Manager" in this version of the OS, it perpetually shows that it's "updating" the various details about memory usage, etc., and the buttons to clear the cache or clear data are perpetually greyed-out.

    So I clicked the only button available which was to "Uninstall Updates". I figured that might roll it back to a previous version. But what it actually did was to completely uninstall it!

    So now I have no Google Play Services installed, and that won't allow any of the Google apps to run, of course, but my battery is a lot happier, and maybe I can at least use the thing as a phone for a while.

    Also, it's clear that Google Play Services must be over 400 Megabytes in size, because I've got a LOT more free device memory now, without that installed.

    I can't use GMail or the like on my phone, but that's not the end of the world. I just use that as my junk mail service, anyhow.

    I will probably reload Google Play Services and see if the version matches what my wife's phone has. If it does, then clearly there's more to this than the version of Google Play Services. Identical hardware and firmware should behave the same with identical software. If it doesn't, then there's something else I have running on my phone that's interacting with Google Play Services to cause the problems.

    But since other people have reported that doing a factory reset and NOT installing ANY of their apps again still results in Google Play Services sucking down their batteries, that seems unlikely.

    I will check her phone against mine and see if there are any differences in the version of Google Play Services. If there is, then maybe we can get a copy of the version she's got, and maybe, for some reason, it doesn't automatically update. Hers is working at this time. Then again, maybe her phone just hasn't gotten around to updating that giant bunch of code. It's a mystery, that's for sure!
    07-05-2016 04:17 AM
  19. robertrj's Avatar
    Interesting finding, jsigmo. Would be nice to check which is the version of Google Play Services running in your wife's phone.

    What really bugs me is that I'm here with an older Android version (Gingerbread). Would be really surprising if her phone, with a newer system, has been using an older app version than mine, for example.

    I know nowadays app developers don't care much about compatibility with older versions. I have been experiencing this with my iPod touch: there were some games and apps that always demanded the newest version running. Ok, but if they want us to have the newest version installed, they should be careful about making it compatible with older systems, that were running when their apps were launched. I don't know, just my opinion...

    Other thing that I noticed is that, in some random moments I notice the sync symbol (those 2 arrows rotating) showing up and then disappearing. This never happened, because I always kept my auto updates completely off, only noticed it when I manually sync something, like Gmail or Calendar. I know it doesn't add much, but shows how this stupid new update keeps the phone awake and also access my data service without my permission...

    How I miss old times... My old Nokia didn't had those updates, battery lasting for a week...
    07-05-2016 07:40 PM
  20. jsigmo's Avatar
    Well now, this just gets stranger, but maybe I've at least come up with some resolution, even though it's not entirely satisfying or satisfactory.

    Recall that I used Samsung Keis to back up the phone, then update it to what they had as the latest operating system version last night.

    This morning, I turn the phone on, and AT&T has an update for me! I'd checked them for updates yesterday, prior to doing the Keis update, and they (AT&T) had none. Their system said I had the latest from them.

    But after updating using Kies, now AT&T did have an update for me. So I let it update over the network to whatever it is that AT&T considers their latest version.

    Keep in mind that AT&T (and perhaps other providers) seem to make their own versions of any release of the Android system. This is so that they can force their (AT&T's) proprietary software down your throat (you can't disable or uninstall a lot of it) and it usually has some way of getting more money from you. An example is their navigation program, which, if you elect to use it, suddenly adds about $10 per month to your phone bill. They also disable the ability to use your phone as a WiFi hotspot, even though the Android system has that feature. If you want to use that, you have to pay AT&T even more. And I'm sure that's just the tip of the iceburg.

    So anyhow, AT&T doesn't want us to have the Samsung version of any OS. They want us to have the AT&T modified version. Well, I went ahead and let it update because I hoped maybe their version fixed some bug that interacts with the Google Play Services to cause the problem.

    After updating, though, the phone still had crashes of Google Play Services, and when I removed it again, then I started having a LOT of battery drain from something called "media". Further, whatever was going on filled all of my phone's memory. I had 30 bytes left very soon.

    So nothing would run, and there didn't seem to be any way to remedy this.

    So I did a factory reset on the phone. I figured I had nothing to lose, especially since I'd backed everything up just last night.

    AT&T then wanted to do yet another update of the OS! So I just let it do it to me.

    Now things seem to be working fine. No crashes of Google Play Services. No excessive battery drain. Of course I'll need to set things back up the way I want, but that's not a huge deal.

    But I'm finding that now, I must use "Synch" to let any of my email work. I'd studiously avoided that up until now. I do NOT want or need my phone to be "synched" with anything but itself. It's its own device. And I don't need my various email accounts merged and scrutinized by Google. I don't need my photos from one device or computer synced with anything else. I don't need texts merged with emails or phone contacts, etc. I can handle any syncing myself.

    Maybe it's just a terminology thing, using this word "sync" but it is, quite frankly, ominous and frightening to me.

    Big Brother is forcing us to merge things that we want to keep separate. I'm sure they want to mine all of our connections and contacts and use this for advertising and social engineering (or worse).

    Anyhow, I, too, find it annoying how Google has forced this on me, and presumably billions of other people.

    But the darned phone seems to be working now. If I was a conspiracy theorist, I'd think... Never mind.

    Anyhow, my phone now has the following:

    Model number: Samsung-SGH-1727
    Android version: 4.1.2
    Baseband version: 1727UCNJ3
    Kernel Version: 3.0.31-844945
    Build Number: JZO54K.1727UCNJ3

    And my Google Play Services is:
    Version: 9.2.56

    And lo and behold, the App Info now shows the storage space, etc., and is not endlessly "updating". The sucker is 107 Megabytes.

    And as for permissions, well, there's not much it doesn't have access to.

    I took some photos of the various versions on my wife's phone, but the factory reset of my phone wiped those photos, I'm afraid. So I'll have to get it and look again later. But it may be that I now have exactly what she has.

    Oh, and another interesting thing. She said that today, she picked up her phone, and found that it was in the middle of updating all sorts of Google apps, and she had NOT asked it to do so. It was just doing it on its own. She stopped it from doing it.

    I don't know what to make of it all. But for now, my phone seems to be behaving nicely. But Google got what they wanted, and now I have their latest versions of everything for good or for ill!
    07-06-2016 02:49 AM
  21. robertrj's Avatar
    Thanks for the info jsigmo, glad now it is working.

    I will see about this Kies update. Honestly I have not used Kies here, because it used to be very computationally intensive in my old computer, and even after upgrading to a new one I never thought about using it. I do manual backup of the things I find more important, like some photos and all.

    But, I'm not sure if here in Brazil there is a kind of provider update like you had with AT&T. I notice my phone has some apps from my provider, not many and that don't bother much, and I never noticed it providing its own updates. Well, I will try this weekend when I have more time.

    Honestly, I am not in a good mood of upgrading my Android. I'm used to this one, and I find unnecessary to have to upgrade a phone that has been working ok some weeks ago because of a single app from Google that is clearly with problems (considering it was not an intentional problem).

    Not sure if anyone is still looking here, but I found something curious today, checking on my CleanMaster app (for those who don't know, it is an app that cleans junk files and free memory). Checking the junk files list, I notice that I always have around 200 Mb of cache files, half of it from Gallery. I'm not 100% sure, but I believe the Gallery cache is used for thumbnails, to make it faster to access images. And I never noticed it being this big: usually the gallery cache grew in size after I was browsing the photos. But if I kept it still, it was always with small size cache.

    Battery draining fast - started on 6/23/2016-sc20160706-205021.png
    Worst part is: I clean the cache, I go check it again in some minutes and it is all back there!

    Similar thing happens with memory. I notice some apps that were never there, like the default Email one and Google+. Of course they don't consume a lot of memory, but still, makes me wonder why they are running in my phone now.

    I'm taking a look at some Google forums, and I'm noticing some people seem to be solving the problem by upgrading their Android. Makes me wonder if this is the only option...
    07-06-2016 08:20 PM
  22. jsigmo's Avatar
    Thanks for the status report from your end, too robertrj.

    It might be worthwhile to install Kies on your latest PC and try it. It is nice to be able to back up all of the contacts, photos, text message history, notes, etc., easily with it, and then be able to restore it all easily as well.

    I'm not sure about the Galaxy Ace 2, but for our two Skyrocket S2 units, I had to download the old version of Kies. It's version 2.6 and Samsung has it on their website along with the newer version. They explain which phones require which version. It has to do with the version of Android that the phones use. For us, we needed the older version. So check that out and make sure you are getting the version of Kies that's appropriate for your phone.

    I've always had trouble with Kies communicating with the phones when running it on my laptop (Win 7 Pro), and this last go-round was no different. It would kind of connect, but it would have trouble when I actually tried to update the operating system.

    So I installed Kies on one of my other PCs (a desktop also running Win 7 Pro), and it works flawlessly from that machine. Samsung does warn you to use only a Samsung USB cable, but I tried several on the laptop and none of them worked, but the first one I used on the desktop PC worked fine. It could be a USB cable issue, but one of the ones that did not work for me on the laptop was a Samsung cable. Who knows?

    But I guess the point is that the communication does seem touchy, so if you have problems, try different cables and even different PCs until you find a combination that works.

    With it all working, I sort of like Kies now. I think I'll use it to periodically back up things from my phone.

    It may be that the newest version of Google Play Services requires that you have the very latest revision of phone firmware (OS).

    At this point, I don't have very many apps re-installed on the phone. And I have a lot more free memory than I did before. Before I did the factory reset, I did notice a HUGE number of what looked to me like random temp files filling the root directory. I mean something like 1700 of them! I was going to just delete them, but when I tried, that didn't seem to actually work. They were just back again after I thought it had deleted them.

    When you connect your phone to the PC with Kies running, it will take a while to connect. But once it does, it will check the operating system to see if it's the latest version, and let you know if it isn't.

    It may be that you'll have to update to the latest OS release for your phone, but you may also have to do a factory reset, too.

    Make sure you back everything up before you do either of those, of course.

    And then it'll be interesting to see if your provider also then has an operating system update for you. They may not. AT&T likes to have complete and total control, so they do that. Other providers may be perfectly happy with whatever the phone manufacturer provides.

    And that would be better for you. You probably get to use your phone as a WiFi hotspot without paying extra to your provider (as is supposed to be the case). With AT&T, you must pay them something like an additional $10 per month if you want to use what is supposed to be a built-in feature (that they've disabled in their version of the OS).

    But I never really want to use that feature anyhow because it would just run up your data usage on your data plan and potentially cost a lot that way. Still, it's aggravating to have features disabled by the provider so they can charge you to re-enable them the way the OS was intended to be in the first place.

    As for the general feel of the upgrade for me, from 4.0.4 to 4.1.2: I have to say that I like a lot of what's different.

    One thing that always bugged me about the old version was that to turn the volume up or down for the "notifications" (such as receiving an email or text), I had to open the tools menu, go down to Sounds, then go through several other steps to get to where that can be adjusted.

    With this new version, I can just use the volume up/down key, and a little menu shows up with a tools icon on it, and pressing that, I have access to that "notifications" volume. So that saves a bit of time every morning and evening.

    Some of the look and feel is also nicer.

    So far, with my very limited installed apps, it's working fine. It may well be that a guy should periodically do a factory reset just to get rid of garbage that's collected over the years. Kind of like wiping the HD on a PC and doing a clean re-install of the OS and any software that you actually want to be using.

    Good luck with your phone. I hope I've got mine running well for another few years now!
    07-07-2016 12:55 AM
  23. Max2598's Avatar
    My tablet was back working like before this afternoon. Six hours on battery, and still 75% of battery left. There must have been a forced update, because I didn't do anything special. I noticed that the package name that was mainly responsible for draining the battery (com.google.android.gms) had been changed ("persistent" has been added at the end).
    Unfortunately, it didn't last long. Tonight, there seem to have been another change, update maybe: the battery started draining really fast again, the tablet constantly awake, and the damned package is back!
    The change is clearly visible in the screenshot below.
    Attached Thumbnails Battery draining fast - started on 6/23/2016-screenshot_2016-07-07-21-48-45.png  
    07-08-2016 12:55 AM
  24. robertrj's Avatar
    Well, I think I found something. I was browsing some Google Play forums, found one in Spanish where I found some people with a temporary solution. So far it works.

    To try to help the others, here is a list of the things I did:

    > First, I have deactivated all kind of sync features, like background data, location, account synchronization, etc.
    > Also, in the Google Play Store app, I turned off all the automatic updates, as well as notifications of new versions.
    > As recommended at the forum, I search in the Internet for an older Google Play Services apk, specifically from version 7.3.29. Downloaded it straight from my phone
    > In my particular case, I had to allow the installation of apps that are not from Google Play (Settings > Applications > Unknown Sources)
    > To avoid any connection, I put my phone in Airplane Mode. Thus, wifi and data completely off (to make sure the battery draining app wouldn't be downloaded without my consent again )
    > Back to Settings > Applications, I uninstalled the Google Play Services that has been causing me so much trouble
    > Searching at my download folder, I installed the apk from the older version (I used the default Android apk installation feature, there were others too)
    > Restarted my phone, and then turned off Airplane Mode.

    I would like to point that at first it didn't seem that it was working. I could still see my battery consumption with Google Play Services at the top (later I found out why, or at least I think). At first I was disappointed, even wrote in the forum that it was no good for me. Put my phone to charge in the evening until it was full, then turned it off and went to sleep.

    In the morning, I saw the battery was not so low as usual, showing a typical 5-10% I was having after turning it off at night (my battery is old, I believe this is expected). Just to check, I looked at battery consumption, and Google Play Services was with a insignificant 2%!

    And so far, so good. It is 20:45 and my battery still has 66% after the whole day. It is important to notice that I'm still using the Energy Saving feature, but seems like it is ok now.

    I haven't touched any of the sync features yet. Still, I tried my Gmail app and sync my emails, all worked fine and battery consumption was not affected.

    Well, but as soon as you set accounts to sync, the power-hungry new version of Google Play Services comes again, as reported by a guy in the forum. I have not checked yet how it happens if I try other things, like turning on GPS for example. But, I'm managing to use my phone, see my emails once in a while and get messages, so it is fine for me for now.

    I noticed right now that I have to update my Whatsapp version. Well, I will use it as a test, because I will have to go to Google Play Store to get the newer version of Whatsapp.

    At least, I guess I have a procedure now. I'm keeping the apk of the older version in my phone, so in any situation I notice battery draining I will check if the new version was downloaded, then I will do it all again.

    Anyway, this is a temporary solution. I still wait for Google to provide a definitive one. What really makes me worried is that until now there was no kind of official comment from Google, saying they are aware of it and are working to solve this problem, which I hope it is just a bug. Let's see what happens.
    07-08-2016 07:55 PM
  25. robertrj's Avatar
    Me again... As I imagined. When I tried to update my Whatsapp, I had to turn out background data. Ok,did that and went straight to Google Play Store to update my Whatsapp version.

    Then, what happens? It shows "download is pending"...

    Stayed like that for some minutes, and then by curiosity I decided to check what version of Google Play Services was there. And again, 9.2.56 version is back...

    Did all the procedure again, and it seems fine now. Hope it stays like that
    07-08-2016 08:23 PM
27 12

Similar Threads

  1. Android auto starts on phone but black screen in car
    By AC Question in forum Android Auto
    Replies: 4
    Last Post: 06-28-2016, 05:07 PM
  2. Lock screen stays on when fingerprint scanner used.
    By Original Newk in forum Samsung Galaxy Note 4
    Replies: 1
    Last Post: 06-27-2016, 01:20 PM
  3. YouTube app new update disabled 720p on most phones
    By Hunork3 in forum General Help and How To
    Replies: 2
    Last Post: 06-26-2016, 09:25 PM
  4. Battery issues... Why is my device shutting off?
    By Didier DJ in forum Samsung Galaxy Tab 3
    Replies: 1
    Last Post: 06-26-2016, 01:27 PM
  5. Spilled water on Galaxy s3 and now wont charge
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-26-2016, 09:54 AM