1. AC Question's Avatar
    I just purchased the recently released U.S. Unlocked Galaxy S7 phone (can't add link because the site for some reason is recognizing it as spam).

    This is model number SM-G930U. It's supposed to support all bands for U.S. carriers. I'm currently with AT&T and I'm unable to obtain 4G LTE. I've brought it to the AT&T store and they said they set all the APNs, updated the IMEI#, and checked everything but the best speed I can get is H+. I've tried restarting the phone as well and still don't get 4G LTE.

    Anyone know how I can fix this? I plan to return the item otherwise...
    07-05-2016 08:51 PM
  2. fiveintow's Avatar
    Did you ever find a solution to this? I'm having a similar issue.
    07-10-2016 09:22 PM
  3. aghahary's Avatar
    I got my SM-G930U phone a couple of days ago, and am having the same problem. AT&T techsupport support told me that since this is an unlocked phone, it can't get to LTE network, which does not sound right. Samsung told me H+ is actually faster than LTE, which is not correct based on my research. I don't know what to do next. Would appreciate any updates from people with the same issue.
    07-15-2016 08:38 PM
  4. Tuckerbear8324's Avatar
    Just received an over the air update to my unlocked US Samsung S7, model SM-G930U. Now listed as build number: MMB29M.G930UUEU2APG9. Android security Patch: August 1, 2016. It is on the AT&T network. Still registers as h+ for speed on the notification panel. Tried Speedtest. No improvement over last original stock build. I haven't noticed any changes or additions so far.
    08-23-2016 08:37 AM
  5. magic25's Avatar
    I ordered a U.S. unlocked Galaxy S7 (SM-G930U) to use on AT&T, has anyone gotten LTE without problems/workarounds? I notice the G930U is missing band 17, one of AT&T LTE bands.
    08-26-2016 04:31 PM
  6. Tuckerbear8324's Avatar
    magic25,
    I'm still at h+ for speed which according to a speed chart should be good for up to 42Mb/s. h+ is considered network generation 3.5G. 4G begins as LTE CAT 2 and has download speeds up to 50Mb/s. The next level 4G is LTE CAT 5 which is up to 300Mb/s. Finally the latest generation is 4.5G know as LTE Advanced with sppeds of up to 1000Mb/s. Speedtest has showed a best of 8.4Mbs for my SM-G930U. and I also received a major update Monday that did nothing for speed, but bumped my security to August 1, 2016. I/m going to go down to my AT&T store and see if they have a branded AT&T S7 and see what speed it gets vs mine. I may also go over to my old carrier Verizon and see if they will swap a Verizon sim and see what I get. I'll post what I find. Sorry magin25 I could not respond to your private message; I could not figure how to reply.
    magic25 likes this.
    08-26-2016 05:17 PM
  7. Tuckerbear8324's Avatar
    GOOD NEWS!!!
    I now have LTE speeds on my Samsung unlocked SM-G930U on AT&T. I getting download speeds of 48.2 Mb/s vs 8.4.
    It took over an hour on the phone with AT&T. Here is what we did. go to: https://www.att.com/esupport/article...less/KM1062162
    Go to Settings, Mobile networks, Access Point Names. Click on more in the upper right hand corner. Select reset to default. Power off the phone for 2 minutes. Power back on and go to the Access Point names page. You should only see "ATT Nextgenphones" Select that, power off again. Enter the settings listed on the AT&T article KM1062162. Power off, then on. Go to Data usage in settings turn Mobile data off, then on several times. Reboot again. I then had LTE showing on the notification bar. BEFORE YOU DO ANY OF THIS GET AN AT&T TECH SUPPORT PERSON ON ANOTHER PHONE. THEY WILL HAVE TO MAKE SOME CHANGES ON THEIR NETWORK WHILE YOU MAKE THE CHANGES OUTLINED. I make no guarantee as we tried many things before hand, but this is what worked to the best of my memory! At 73 years of age, my memory isn't as good as it was when I was an I/T manager 15 years ago.
    magic25 likes this.
    08-27-2016 12:49 PM

Similar Threads

  1. Verizon phone on AT&T?
    By kach474 in forum AT&T
    Replies: 7
    Last Post: 07-11-2016, 06:58 PM
  2. Replies: 1
    Last Post: 07-05-2016, 09:51 PM
  3. my recent app button is not working why?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 07-05-2016, 09:39 PM
  4. Replies: 1
    Last Post: 07-05-2016, 09:07 PM
  5. my recent app button is not working why?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 07-05-2016, 07:44 PM
LINK TO POST COPIED TO CLIPBOARD