1. AC Question's Avatar
    Hi. I have a LG Optimus L90 phone and my GPS has not been working. I can't pinpoint when it had stopped because I rarely use it. I tried using it today to test out Pokemon Go (a new game that uses GPS to move your character and catch pokemon) but it had said "No GPS signal found." and placed me where the last signal was, at my house. My settings seem to be correct on the phone itself. Location is set to on with the settings at the most accurate settings (using cell data and wifi or something like that). I went onto google maps to find the same thing, it placed me at the house and even when I went for a walk in the park the blue dot stayed put. I downloaded a GPS status thing and it didn't seem to pick up anything, even when I reset my GPS and downloaded again. It just said it was looking for the GPS signal and never told me error, it just kept looking for it. The compass still works. I'm just wondering how to fix my GPS in my phone.
    07-06-2016 09:52 PM
  2. Suspicious Xebra's Avatar

    I just registered because I was having the same issue and I found something that worked. Two things for you to check. First, try turning WiFi on (you don't need to connect to wifi, just have that on). It was working for me until I turned WiFi off (i was at the edge of the wifi signals range and I didn't want to deal with a weak signal) and that killed the app's GPS. Turning it back on made it work.

    If that doesn't work you need to make sure Mock Location is disabled. If you have developer mode enabled just go to that and uncheck Mock Location. If you don't have developer mode enabled then do the following. Go into Settings --> General --> About phone --> Software info and rapidly tap on Build Number 7 times (you will see a little blue box that will pop up and say how many more times until you enable developer mode). Once that is enabled go into Settings --> General and scroll down until you see Developer Tools. Go in there and look for Mock Location and make sure it is UNCHECKED.

    All that said, I have been experiencing very poor GPS positioning in this app (it says I a block away or so from where I am half the time). I have no idea what to do about that and have submitted a bug report to the company about it.

    Hope this helps,
    pewpeed likes this.
    07-07-2016 11:29 AM
  3. pewpeed's Avatar
    Hey, John.

    I have tried both of your methods, and neither of them brought a permanent solution. Does the turning-on wifi still work for you? Are there any other solutions that may work for me?

    I have tried:
    • Turning off mock locations
    • Turning on wifi
    • Turning on high accuracy for my GPS
    • Restarting my phone
    • Turning on and off my data and GPS

    07-13-2016 11:09 PM
  4. tad45's Avatar
    Same here. I never used the GPS before Pokemon Go, but now I realize if I ever really needed it, it would be useless. At best, my location shows me at the house next door when I'm at home - often it shows me a full block away. I tried using the GPS Status and Toolbox app and it shows me connecting to 0 out of 21 available satelites. Wifi is on, GPS set at high accuracy, mock location is unchecked. Maybe this phone just has a crappy GPS?
    07-14-2016 10:51 AM
  5. pewpeed's Avatar
    TL;DR solution: Keep wifi on/enabled for better GPS tracking; restart phone of getting "GPS signal not found" issue

    Hm, well I've tried keeping my wifi on over my 4-hour journey today, and my GPS was A LOT more accurate and consistent than without it on, so I can confirm that this DOES work.

    Also, I tried out something new today as well, and I think it kind of solved the "GPS signal not found" issue. What I did was that, every time I got the "GPS signal not found" issue, I immediately restarted my phone. This seemed to work for me because I only got the "GPS signal not found" issue about 3 times in a 4-hour period, instead of 50+ times on my previous days. Those 3 times that I did have to restart today was only about once every hour, so that's not bad imo.
    07-14-2016 07:52 PM
  6. Lordsquid's Avatar
    I have the same problem. I checked mock settings which was off, so I tried turning on WiFi. This didn't work either. It just connected to WiFi networks that Couldn't connect to the Internet and couldn't find a GPS signal.
    07-16-2016 09:03 PM
  7. pewpeed's Avatar
    Are you able to disconnect from those wifi networks? And try restarting your phone if your GPS can't connect.
    07-16-2016 11:32 PM
  8. Ben Gruman's Avatar
    I too have had very little success with my gps. I always have Wi-Fi on, I have mock locations off, and whether or not it works I'm not satisfied with simply restarting my phone every time my gps doesn't lock. I will add that there are a few of those "gps fix" apps that have been able to catch a signal rather quickly (around 20 seconds, and I'm in my room with the blinds closed, also on "device sensors only" so I know it's not cheating by using the other radios), which seems to say that the hardware is fine and something about the way Pokémon and Google operate the gps is faulty.
    07-17-2016 08:13 PM
  9. perotoss's Avatar
    I'm having the same issue with Ingress - it takes a long time to locate me. GPS Test also takes a long time to get a fix. From what I've read in other forums, it seems like a hardware issue.

    But I found this post about opening up the phone and cleaning the antenna contacts - it's worth a shot:

    D-415 GPS issues - Post #26
    07-19-2016 11:29 AM

Similar Threads

  1. Xfinity hijacking my wifi - can anyone help?
    By Kelly Parkinson in forum Samsung Galaxy S4 Mini
    Replies: 2
    Last Post: 07-08-2016, 07:05 PM
  2. Replies: 0
    Last Post: 07-06-2016, 09:47 PM
  3. Replies: 0
    Last Post: 07-06-2016, 09:44 PM
  4. How can I reset my Private Mode pattern?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 07-06-2016, 09:39 PM