1. AC Question's Avatar
    Hi everyone,

    I have a Samsung Galaxy S6 running Android version 6.0.1 and been travelling with my phone around Europe for the past 4 weeks - using Google maps as my help (gps basically) - and it worked mostly fine until two days ago. I had the odd issue that it logged onto a location that I have been at when I first arrived in the UK but for the past two days it constantly either says - GPS signal lost OR gets stuck in the "searching for gps"instead of giving me directions. I am really frustrated by now - I have cleared the chache - unistalled and reinstalled updates for Google maps already but no avail.

    I need help to fix this as I am driving a lot of backroads that are very narrow and hard to find on a regular map - I also tried downloading offline maps but it did not make a difference.

    So could it be the the actual GPS chip (or whatever it is in the phone that lets location work) is faulty. mobile data works fine and is turned on of course and so is the location icon.

    Are there any other re-sets (bar a total factory re-set) I can try or is the actual phone perhaps faulty?

    Thanks!!!
    07-07-2016 01:19 AM
  2. Rukbat's Avatar
    It's usually not the hardware. Open the phone (the app) and dial the following number:

    *#9090# -- Diagnostic Configuration (*#197328640# if that doesn't work)
    Menu, select Key Input, enter Q
    Menu, select Key Input, enter 0000
    wait for the next menu. (It takes a while.)
    UMTS->COMMON->NV REBUILD->NV REBUILD->SYSTEM->PROTOCOL->GPS->IMS
    or, if you don't have UMTS:
    UE SETTINGS & INFO->SETTING->SYSTEM->NV REBUILD->ALL

    Restart the phone.

    That should fix it, at least for a while.
    07-08-2016 06:35 PM
  3. flaxworxNZ's Avatar
    Thanks heaps! Tried it - got the first screen and done the two key input but then nothing - how long is a while...? 20 min so far? I did not even know there was such a thing on a phone - so thanks so far!
    07-09-2016 12:52 AM
  4. andoc's Avatar
    Hi there,

    Sorry to hijack your thread but I'm having the same problem on a samsung galaxy s5. Rukbat - do you have the USSD code's / help for a galaxy s5? Seems to appear my GPS is broken. Have also tried downloading the apps ... GPS status & toolbox, GPS test & another called GPS status and none can find any satellites, just keeps searching!!

    Please help, so frustrating
    10-06-2016 09:16 PM

Similar Threads

  1. Samsung launches new line of UFS-based memory cards
    By D13H4RD2L1V3 in forum General News & Discussion
    Replies: 3
    Last Post: 10-19-2016, 04:54 PM
  2. Replies: 1
    Last Post: 07-08-2016, 06:32 PM
  3. facebook downloads but won't install (galaxy tab3 os 5.1)
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 07-06-2016, 11:38 PM
  4. how do I tell if my Galaxy s5 is charging?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 07-06-2016, 10:52 PM
  5. galaxy s6 edge screen mirror not working
    By Herbwaltonjr in forum Ask a Question
    Replies: 0
    Last Post: 07-06-2016, 10:40 PM
LINK TO POST COPIED TO CLIPBOARD