1. nikhilsuresh7's Avatar

    My Sandisk Ultra 32GB microsd card is not getting mounted on my Moto X Play from yesterday on. It was working perfectly before that.

    Problem in Detail: Yesterday when i tried to play some music only I realized that its not getting mounted. I tried removing the card and reinserting it. But it's not showing up any notification. When I went to Storage and USB settings suddenly, its showing 'Unsupported' for a minute and is getting unmounted automatically.

    Just after I re-inserted SD Card: http://i.stack.imgur.com/yCIKM.png
    After 1 minute: http://i.stack.imgur.com/xCXqA.png

    Possible Cause: One of my friend connected my phone with USB cable to his laptop day before yesterday for transferring data. I dunno exactly whether its infected or he didn't eject it properly.

    What all I Tried: Initially, I tried connecting it to my laptop using Card Reader. Fortunately, everything was fine inside the system. The file system FAT32, all the data it had, and no memory was unallocated. Afterwards I did a quick format and a complete format as well, with file system FAT32. Both didn't help anyway. Then I installed mini tool partition wizard. But haven't done anything with that yet.

    NOTE: I have already searched a lot for the fix. But I didn't find anyone having the exact problem. Either they have unallocated space in usb, or their card is not showing up on system and the chkdsk command seems deprecated. Kindly help me with this ASAP.
    07-24-2016 02:11 AM

Similar Threads

  1. Replies: 1
    Last Post: 07-24-2016, 06:33 AM
  2. Replies: 0
    Last Post: 07-24-2016, 02:08 AM
  3. Has anyone heard of a Samsung Note7 in White Pearl?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 07-24-2016, 01:42 AM
  4. Replies: 0
    Last Post: 07-24-2016, 01:18 AM
  5. Why would an LG Phoenix 2 GoPhone not read a SIM card?
    By rdavis1121 in forum Ask a Question
    Replies: 0
    Last Post: 07-24-2016, 01:12 AM