1. AC Question's Avatar
    I am unable to download anything from the play store, it says downloading but nothing happens, happening to all apps, tried clearing cache and data on the app store on download manager, uninstalled all updates on the play store, removed the Google accounts and added back in, still the same thing, rebooted the phone and still happening, please can someone help?
    07-30-2016 11:54 AM
  2. H3aTeRzz's Avatar
    Hi There!

    Don't know what phone you have, but also try to enter recovery, (if possible) and wipe the Cache Partition. If you've done this, I don't see any other option but to back up your personal data, and do a Full Factory Restore.

    07-30-2016 06:04 PM
  3. B. Diddy's Avatar
    Welcome to Android Central! Which device? Does this happen on both wi-fi and mobile data?
    07-30-2016 10:29 PM

Similar Threads

  1. Note 2: 'NOT REGISTERED ON NETWORK' problem
    By Nomisso in forum T-Mobile Galaxy Note 2
    Replies: 3
    Last Post: 07-31-2016, 10:17 PM
  2. Samsung note 3 touch is not working
    By AC Question in forum Samsung Galaxy Note 3
    Replies: 1
    Last Post: 07-30-2016, 02:40 PM
  3. How to get an app removed by Google Play
    By AC Question in forum Ask a Question
    Replies: 3
    Last Post: 07-30-2016, 09:39 AM
  4. Replies: 1
    Last Post: 07-30-2016, 06:45 AM
  5. Replies: 1
    Last Post: 07-30-2016, 05:37 AM