1. AC Question's Avatar

    The issues are in relation to a Samsung Galaxy Tab Pro 10.1, running 4.4.2.
    I accidentally let the device go flat (I am aware this is not good for the device). After recharging and restarting the device, the device appeared to have lost a lot of my setup. Any app related to Google has disappeared, and my launcher and home screen setup have reset.

    I have removed and readded the Google account, and reset the date and time (they had set themselves to some time in 2012).

    Initially, I tried to reinstall Google Play Services and the Google Play Store through he Google Play website, but received the message 'Application will be downloaded shortly.

    I then attempted to reinstall Google Play Services and the Google Play Store directly from the APK. They both claim to have installed properly. I am able to open the applications (most times). However, as soon as I try to do anything within the Play Store, it crashes.

    I am at a loss as to how to return my tablet to a state even remotely resembling how it was. Is anyone able to help?

    08-03-2016 02:56 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Is this device rooted? Was it originally intended for the Chinese market, or somewhere else where Google services are blocked? If not, then Google Play Services and Google Play Store should already be preinstalled on the device, and they should auto-update on their own.
    08-03-2016 03:18 PM
  3. redheadrebby's Avatar
    I am the original poster, now with an account.
    The device is not rooted as far as I know. It was not one intended for markets with no Google service access.
    Prior to the device going flat, all Google services were functioning fine. They were preinstalled on the device. However, they appear to have uninstalled themselves. After reinstalling from the APK, I tried clearing the cache and the data. I also tried removing the updates from these apps and restoring to factory versions; this completely removed the apps.
    08-03-2016 04:14 PM
  4. B. Diddy's Avatar
    That's odd. If it's not too much trouble, do another factory reset, then before doing anything else, look in the App Drawer (or App Manager) and see if you Google Play Store is present. Remember that it might be in a Google folder in the App Drawer.
    08-03-2016 06:47 PM
  5. redheadrebby's Avatar
    I would rather not factory reset if there's another option, as that would lose any other settings and data, wouldn't it?
    08-04-2016 02:24 AM
  6. B. Diddy's Avatar
    And just to confirm--if you go to the App Manager and select Google Play Store, it has an Uninstall button, and not an Uninstall Updates or Disable button? Again, with a genuine Android device intended for most major markets, the Google Play Store should be preinstalled, which means it can't be uninstalled.

    Run Root Checker to make sure the tablet is not rooted.
    08-04-2016 12:54 PM
  7. redheadrebby's Avatar
    It doesn't have an uninstall button, it has an uninstall updates button. I've attached an image of the screen. However, if I press the uninstall updates button, it comes up with the message 'Uninstall updates and return app to factory settings?', but then removes the Play Store from the application list entirely. (The same applies to the Play Services)
    The device is not rooted. I had to download the app through an APK, as the Play Store online insisted it was already installed, and again gave the message of 'This app will be installed shortly.
    Attached Thumbnails Tablet Lost All Google Apps and Unable to Re-add-20160804_194358.jpg  
    08-04-2016 01:55 PM
  8. B. Diddy's Avatar
    When you Uninstall Updates, and the factory version is reinstalled, are you saying it disappears from the App Manager completely, or the App Drawer? Is there an option in the App Manager to show or hide system apps, or does it have a separate list of Downloaded apps and All apps?
    08-04-2016 02:11 PM
  9. redheadrebby's Avatar
    It disappears from the app manager completely, under all lists.
    There does not appear to be any option to show/hide system apps.
    08-04-2016 02:15 PM
  10. B. Diddy's Avatar
    That is just really strange. Maybe the firmware became corrupted. See if you can reinstall the firmware by using either Samsung Kies or Samsung Smart Switch.

    SmartSwitch: Install & update or replace firmware
    Kies - How do I Restore my original Samsung ROM (remove custom OS ROM) using Kies 3?
    08-04-2016 07:00 PM
  11. redheadrebby's Avatar
    As restoring the firmware would have lost data too, I decided to go for a factory reset.
    From initial use, this seems to have worked.
    Thank you for your help
    B. Diddy likes this.
    08-05-2016 09:10 AM

Similar Threads

  1. I lost my All data when i connect with pc
    By Nowty Prince in forum Android 5.0 Lollipop
    Replies: 1
    Last Post: 08-06-2016, 02:00 AM
  2. Sound Comes though Speakers and Headphones
    By GeoJono in forum Moto X Pure Edition
    Replies: 3
    Last Post: 08-05-2016, 09:51 AM
  3. Android/Google update fail
    By Steve_Rose in forum Samsung Galaxy S7
    Replies: 2
    Last Post: 08-04-2016, 11:42 AM
  4. Why can't Androids connect to my employer wifi
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 08-03-2016, 03:19 PM
  5. Replies: 0
    Last Post: 08-03-2016, 02:49 PM