1. BMAJTZ's Avatar
    Hi, i have a question about one app i am trying to identify and basically get rid of. My mobile phone is Elephone G2 with android 4.4.4 and i use KK launcher. It really often happens that some applications are installed without my permission, i have no idea why. Right now there is one i have no idea what it is. It seems like Widget on the start screen, it looks like green circle with percentage number inside

    Image 1

    when i click on it it looks like some kind of memory cleaner

    Image 2

    but after few seconds will pop up some kind of ads:

    Image 3

    I looked into my installed apps and really nothing looks really suspicious, and i really have no idea what is it. It is impossible to uninstall, or at least i did not find the way how to do. It is impossible to get rid of the app icon on front screen, it is not even listed in widged list, and i dont think that this is part of KK Launcher.

    So have you any idea what it is and how to get rid of it, it is annoying as hell.

    And one more think. There are some other adds popping out really often for example this:

    Image 4

    On the top is written something like com.ovs.admob.NativeActivity, what is this one? I found out that admob is some kind of google app but i did not installed it. Please how to get rid of this as well.

    This issues are coming back really often, sometimes is possible to get rid of it but it is always not permanent solution after few days is everything back. I even tried to set it to factory setting, this did not helped at all, i even tried to discard system fully and install another one with bootloader, this helped again only for few days. But now i am starting to be really frustrated about this.

    Thank you.
    08-15-2016 09:56 AM
  2. TenshiNo's Avatar
    Sounds like something you are installing is allowing other apps to be installed. Since you talk about flashing alternate firmware, I assume your device is rooted. Apps that are granted root permissions can definitely install other apps without any prompt to the user, which is one of the greatest risks of root. Make sure you've got your SU app setup to prompt before granting root access to any app, and do not grant root permissions to any app that you do not have very good reason to trust.

    It could also be a component of some other app you have installed, bundled into the app. At the end of the day, you should never install apps from outside the Google Play Store, unless you have very good reason to trust the authenticity of the apk. Most adware/malware comes from installing apps from 3rd party app stores and app piracy websites, where common apps are frequently modified to include "other functionality".

    You said you tried a factory reset. Did you immediately begin re-installing the apps you normally use? If so, it's likely one of those that is responsible. Factory reset, and then don't install anything for a day and see if the problem persists. If it does, it's possible that it's something baked into the firmware that you are downloading, since firmware creators can add apk's to their firmware with root permissions to allow installations of other apps, even if you never explicitly grant that permission.

    Anytime you get software (apps/firmware) from sources outside Google or the device's OEM, you are granting a high level of trust to the source of that software.
    08-15-2016 11:53 AM
  3. BMAJTZ's Avatar
    Do i did factory reset and nothing really happens. Actually the app mentioned above is still there from start, but i am really sure that when i was installing the system for first time it was OK for at least few months. But you are probably right, i will try to find another (hopefully really official) firmware and try to reinstall this whole thing again, because it seems right now that this will be the only solution.
    08-16-2016 02:00 AM
  4. B. Diddy's Avatar
    Welcome to Android Central! I would suspect KK Launcher. The reviews on the Google Play page mention adware: https://forums.androidcentral.com/e?...token=vEHASFvg

    Try reverting to the stock launcher (or try another well-regarded launcher like Nova), and uninstall KK Launcher completely.
    08-16-2016 04:38 AM
  5. Polly777's Avatar
    The very same thing has been happening to my tablet for the last 3 or 4 weeks. I haven't messed around with it by installing anything from outside the Play Store or other third party software. And the only apps I installed were Adobe, Avast, Duolingo, Luminosity, MS Word, Polaris (word processor), Translator & Uber. Also, one of the links that gets placed on my main screen (Aliexpress) tried to make some charges to one of my cards, which are linked to Uber through Paypal. So my bank cancelled my card.

    Already did the factory reset twice, making sure to erase all apps before doing so and it doesn´t help. I had it for about 3 months before this started happening.

    I'm pretty sure my device is not "rooted" (whatever that means) because when I installed the Avast app and tried to turn on its firewall, a notification that says "Device must be rooted".

    The only thing I haven´t erased is my microSD card, which was brand new when I installed it.
    08-31-2016 01:20 AM

Similar Threads

  1. S7 turn off overlays for Facebook and other apps
    By AC Question in forum Ask a Question
    Replies: 3
    Last Post: 09-02-2016, 07:59 AM
  2. Do I update in order to play Fantasy Football?
    By rageboardr in forum General Help and How To
    Replies: 3
    Last Post: 08-19-2016, 03:37 AM
  3. Why is phone not learning new words? help please
    By Richard Shields1 in forum Ask a Question
    Replies: 1
    Last Post: 08-16-2016, 03:49 AM
  4. permission to use Camera is not allowing me take pics.?
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 08-15-2016, 09:50 AM
  5. Replies: 1
    Last Post: 08-15-2016, 09:20 AM
LINK TO POST COPIED TO CLIPBOARD