1. AC Question's Avatar
    My device is stuck in download mode and will not boot. I have tried to hard reset but it locks up on the boot screen and will not boot. Then it will boot to download mode, I'm guessing the firmware is corrupted and needs reloaded.

    I have tried to find this firmware on sammobile and other sites but I can not find it. I have tried to use Kies to get the firmware from the temp folder but Kies wants a serial number in order to restore the device. The only serial number I have is the IMEI and it will not take it, does anyone have a link to the USA verizon firmware or know a way around this serial thing?

    Thank you,
    09-20-2016 09:02 AM
  2. anon(632115)'s Avatar
    Generally the serial number can be found under the battery or if the battery is not removable, on the reverse of the device. Another thought, perhaps Samsung can provide it if you give them the IMEI. You won't be able to find the FW on the usual sites thanks to Verizon
    09-20-2016 09:21 AM

Similar Threads

  1. Replies: 3
    Last Post: 10-07-2016, 08:52 PM
  2. I can't transfer music to my new memory card
    By AC Question in forum Samsung Galaxy S4
    Replies: 2
    Last Post: 09-23-2016, 01:00 PM
  3. Replies: 0
    Last Post: 09-20-2016, 08:23 AM
  4. Replies: 0
    Last Post: 09-20-2016, 07:08 AM