1. BaxterCooper's Avatar
    I've had my nexus 6p for only a couple days now and somethings gone wrong. My phone won't boot up and is stuck on the Google boot logo. When I hold down the power button, it displays a message saying "device is corrupt and cannot be trusted" I held down volume and power button to get to the boot loader which was fine however when I went into recovery the logo of the dead android and no command message keeps flashing between that and a blank screen. I don't understand what's going on, could someone please help me thanks.
    10-02-2016 09:02 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Are you on Nougat? If so, it sounds like the Verified Boot feature has been triggered: Android and chill: Nougat and the root question | Android Central. Did someone try to root the phone?
    10-03-2016 03:28 AM
  3. BaxterCooper's Avatar
    No I've only had the phone for a couple days and don't even know how to root a device. I don't know how my device can get soft bricked without me even rooting it but I think that's my problem.
    10-03-2016 06:51 AM
  4. B. Diddy's Avatar
    Did you buy it new or used? If it was used, then the previous owner may have rooted or otherwise modified the phone.

    Bring it back to wherever you got it and ask for an exchange or refund. If you got it from Google, then contact them for repair or replacement.
    10-03-2016 11:04 AM
  5. BaxterCooper's Avatar
    I bought it new but I tried to fix it and I don't think the warranty will work now.
    10-03-2016 08:00 PM
  6. B. Diddy's Avatar
    You bought the phone 2 days ago, and you've already voided the warranty? Did you try opening the phone up for some reason? Or did you drop the phone, leaving clear evidence of damage?
    10-03-2016 09:12 PM
  7. BaxterCooper's Avatar
    No I havnt done either. But yesterday I managed to fix it and was able to get and is my phone throughout the whole day. But this morning I woke up and it did the same thing again. Except it doesn't say device is corrupt. It just won't boot up.
    10-04-2016 08:28 PM
  8. anon(156377)'s Avatar
    So what makes you believe your warranty won't work?
    10-04-2016 08:36 PM
  9. BaxterCooper's Avatar
    I don't think the warranty will work because I've messed around with device. Tried flashing it and all of that stuff. I got it to work again this morning though but I have a feeling tomorrow when I wake the device will be stuck on the Google logo again and I'll have to flash the phone for a third time.
    10-04-2016 10:17 PM
  10. BaxterCooper's Avatar
    Yep and to no surprise I wake up this morning and stuck on Google logo. So I don't know whether it's got something to do with charging. But over night the nexus reboots, gets stuck on Google logo and when I go into recovery mode, the page keeps switching from the dead android to a blank screen
    10-05-2016 08:50 PM

Similar Threads

  1. "There was a problem communicating with Google servers try again later."
    By AlexAndriod in forum Legacy Android & Other OS's
    Replies: 3
    Last Post: 10-16-2016, 03:03 AM
  2. Samsung S6 Edge Camera problem
    By KhaledAhmed 1 in forum Samsung Galaxy S6 edge
    Replies: 3
    Last Post: 10-02-2016, 11:58 PM
  3. Replies: 2
    Last Post: 10-02-2016, 10:46 PM
  4. [HTC one M7]Problem of tethering
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 10-02-2016, 06:38 PM
  5. [HTC one M7]Problem of tethering
    By play-relaxed in forum Ask a Question
    Replies: 1
    Last Post: 10-02-2016, 05:08 PM
LINK TO POST COPIED TO CLIPBOARD