1. AC Question's Avatar
    So I purchased a Nexus 6p last week to replace my Droid Turbo 2 and I love the phone. It took forever to update from 6.0 to 7.0. As of now I do not have LTE service on my phone, all it says is extended 3G. I have read that there was a bug with 6.0.1 that caused the LTE services to stop working? I Tried all the possible fixes all the way down to a factory reset. Nothing seems to bring LTE up. I am not sure if I even had LTE on the phone when I first received it as it updated right away. I Called Google and they were no help, they said to exchange the phone. I called Verizon and they were perplexed, but he did give me a glimmer of hope and said that it is possible that Verizon is not supporting the 7.0 yet as it has not rolled out on any devices and that could be the problem. He said tomorrow the LG v20 and the Pixel roll out and become active and support for 7.0 begins. So maybe I am guessing that could be the issue, that tomorrow I may start getting LTE? I sure hope so because I like this phone and I really don't want to have return it and wait 2 more weeks to receive another one in the mail.

    Any help would be greatly appreciated! Thank you

    -Mark
    10-20-2016 04:53 PM

Similar Threads

  1. No pics
    By Jims S5 in forum Android Central Apps
    Replies: 5
    Last Post: 04-21-2017, 04:52 AM
  2. Replies: 7
    Last Post: 10-21-2016, 03:21 PM
  3. No bloatware from Verizon? Is this true for all?
    By rvgraham in forum Google Pixel & Pixel XL
    Replies: 5
    Last Post: 10-20-2016, 08:00 PM
  4. Replies: 1
    Last Post: 10-20-2016, 05:36 PM
  5. Replies: 0
    Last Post: 10-20-2016, 02:59 PM
LINK TO POST COPIED TO CLIPBOARD