1. AC Question's Avatar
    I've had my galaxy s5 for over a year. This morning it was fine and now suddenly it won't charge. If it's on when I plug it in, it shows no reaction to the charger whatsoever. If it's off, then it shows a little gray battery symbol with a lightning bolt. I don't know yet if it charges when it's off - just now turned it off and left it plugged in. I tried the thing where you turn it off and hold the power button for a minute...tried the power button and volume buttons...nothing. Anyone know anything?
    11-23-2016 04:03 PM
  2. Tim1954's Avatar
    If it does the same thing with another charger, your port could be damaged, but more likely the battery has reached the end of its useful life and has gone into retirement.
    11-23-2016 11:03 PM

Similar Threads

  1. Replies: 1
    Last Post: 11-23-2016, 11:06 PM
  2. Google won't let me install an app
    By neet1220 in forum General Help and How To
    Replies: 4
    Last Post: 11-23-2016, 08:44 PM
  3. Help with Recovering Device Info! (Galaxy Note 5 & S3)
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 11-23-2016, 03:39 PM
  4. Replies: 0
    Last Post: 11-23-2016, 03:22 PM
  5. Replies: 0
    Last Post: 11-23-2016, 12:54 PM