1. RapGod34's Avatar
    Good evening,

    So I had issues with my wifi on my S3 a few weeks ago. Whenever trying to connect to WIFI, the button would be a grey/green for a few seconds then turn back off. I factory reset my phone and started it in safe mode, which fixed the issue. The internet worked perfectly. Then yesterday it started acting up. It is extremely slow and turns off sometimes, but turns back on later on. I tried factory resetting it and booting in safemode, but nothing has worked. Any ideas what I could do to fix it? Thank you
    12-08-2016 08:32 PM
  2. jeffhaskins's Avatar
    What are you running on it? I had an issue with something similar on CM13 vzw I was running on Straight Talk. Might be a ROM issue unless you're running stock JellyBean.
    12-08-2016 08:44 PM
  3. RapGod34's Avatar
    I believe I'm running stock JellyBean...I didn't root it or anything.
    12-08-2016 08:46 PM
  4. RapGod34's Avatar
    I have obviously tried restarting the router, but it happens to every router that I connect to.
    12-08-2016 09:03 PM
  5. Taylor_Swift_Fan's Avatar
    It could be a modem issue.
    What modem version are you using?
    Try using Odin to flash the latest modem.

    Hit that like button if I helped you!
    12-08-2016 09:25 PM
  6. RapGod34's Avatar
    How do I check what modem version I'm using and is Odin an app?
    12-08-2016 09:34 PM
  7. Taylor_Swift_Fan's Avatar
    How do I check what modem version I'm using and is Odin an app?
    I'm settings about phone and check baseband version should be last three letters and numbers
    12-08-2016 09:53 PM
  8. RapGod34's Avatar
    MJA is the last three for me.
    12-08-2016 09:54 PM
  9. Taylor_Swift_Fan's Avatar
    OK let me do a search for latest.
    What carrier?
    12-08-2016 09:55 PM
  10. RapGod34's Avatar
    US Cellular
    12-08-2016 09:56 PM
  11. Taylor_Swift_Fan's Avatar
    Do you happen to know what similar carrier it could be?
    Att, Verizon T-Mobile?
    12-08-2016 09:57 PM
  12. Taylor_Swift_Fan's Avatar
    Assuming its close to att then try one of these.

    12-08-2016 09:58 PM
  13. RapGod34's Avatar
    I do not..
    12-08-2016 09:59 PM
  14. Taylor_Swift_Fan's Avatar
    I do not..
    No worries I can search for you but it might be a while I'm at 3%
    Make that 1%
    12-08-2016 09:59 PM
  15. Taylor_Swift_Fan's Avatar
    Download the stock modifed (i.e bootloader file removed) MD4 tar file http://anything-android.co/getdownlo...d4-fix.tar.zip

    2. Download the OTA MJA file from http://anything-android.co/getdownlo...a_update_2.zip copy the downloaded file to your SD card

    3. Install the first downloaded MD4 file via ODIN PDA section and after completion of the process and cache cleadning after phone booted up when phone is at "SAMSUNG" logo switch off the phone and boot the phone to recovery mode i.e "volume up + home + power buttons" and select install update from SD card option and navigate to the downloaded file in the step 2 and press OK and it will be install the OTA update package it will take some time for completion and after that phone reboots and now u will be on stock 4.3 MJA

    I copied this from http://www.rimweb.in/forums/topic/36...ficial-update/
    You seem to be on latest baseband. Doesn't hurt to reflahs it
    12-08-2016 10:10 PM
  16. RapGod34's Avatar
    From that post, it appears they have issues with their mobile data not working, mine works, it's the WIFI that doesn't work. Should I still proceed with that process?
    12-08-2016 10:12 PM
  17. Taylor_Swift_Fan's Avatar
    Hmm. Well it never really hurts to try. As long as you have some sort of backup and a general idea of Odin I suggest you reflash the baseband could've been somewhat corrupted through the update you received
    12-08-2016 10:17 PM
  18. RapGod34's Avatar
    Hmmm...I don't have a backup, and I don't know anything about Odin haha.
    12-08-2016 10:49 PM
  19. Taylor_Swift_Fan's Avatar
    Hmmm...I don't have a backup, and I don't know anything about Odin haha.
    O_O I I don't know what to tell you. You could read a guide but I don't think there's another way unless you root and install ROMs or kernels. I'm sorry but if you need any other help feel free to ask me or pm me
    12-08-2016 10:55 PM

Similar Threads

  1. USB to PC - Cannot See All Folders on SD Card (can see some)
    By Lamensterms in forum Huawei Mate 8
    Replies: 3
    Last Post: 12-09-2016, 09:56 AM
  2. Replies: 2
    Last Post: 12-09-2016, 07:26 AM
  3. How do I put my Galaxy Note 5 calls on hold?
    By Janissi in forum Samsung Galaxy Note 5
    Replies: 1
    Last Post: 12-09-2016, 01:39 AM
  4. Replies: 1
    Last Post: 12-08-2016, 05:11 PM
  5. you tube video dont open on my nexus 5x?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 12-08-2016, 04:33 PM