12-17-2016 04:14 PM
27 12
tools Reply
  1. AC Question's Avatar
    Hello, my name is Cássio. I´m facing a problem with my HTC One X. I decided to flash a newer ROM including an Android update but it doesn´t worked properly.
    Just the unlock procedure worked well.
    Now the HOX just start and keeps on white screen (HTC Quietlly Briliant).
    Bootloader is working but not connecting with my notebook (Windows 10).
    I just read lots of treads, lots of searches on InterNet, but I´m facing many questions.
    More than 5 years ago I flashed 3 times my old HTC Wizard but now is too complex !
    What I have to do ?
    USB and ADB drivers are the same ? Do I need both ? Do I need to consider ADB tool for the procedure or any other tool kit ? Is the root process really necessary ? Do I need a Recovery Package like twrp-3.0.2-0-test-endeavoru ? It is not a ROM, isn´t it ? Which ROM do you recommend ? I just want my HOX working back !!!
    Please help !!!!
    Don´t know how to access your answer ! Is it possible use a e-mail at least to start ?

    [Email removed by moderator]

    Thank you in advance !
    12-09-2016 10:58 AM
  2. Rukbat's Avatar
    Just use a ROM flashing tool and flash the stock ROM.
    12-09-2016 12:19 PM
  3. chcgebara's Avatar
    I´m sorry Rukbat, but just this simple answer for that amount of questions ????
    Which flash tool I have to use ?
    Stock ROM ?? What does it means ? Is it just a ROM ?? What about "stock" ???
    What about the drivers questions ???
    12-09-2016 01:29 PM
  4. jeffhaskins's Avatar
    Adb won't be much help without root. You need to unlock your bootloader if it is locked and fastboot flash firmware or at least TWRP.
    chcgebara likes this.
    12-09-2016 01:43 PM
  5. chcgebara's Avatar
    Ok jeffhaskins, thank you for your answer !

    As far as I know, bootloader is unlocked once I have access on it. At the top there is the UNLOCKED info and than infos regarding the HBoot, Radio, etc..Does it means that the bootloader is unlocked, doesn´t it ?
    If so, how about the next steps: drivers, TWRP (if really necessary), ROM ?
    I remember when I flashed, lot of years ago, my old HTC Wizard, I used RUU.
    Which tool am I suppose to use now ?
    Where can I find these files for download (Drivers, tools, ROM, etc.) ? I tried some links but the page doesn´t exist, file is corrupted, etc.
    I´m completely lost !
    In addition, I´m running Windows 10 64 bits on my notebook. Is it a problem ?
    Please help !
    12-09-2016 01:56 PM
  6. jeffhaskins's Avatar
    Yes your bootloader is unlocked. Does it say s-on or s-off?
    chcgebara likes this.
    12-09-2016 02:15 PM
  7. jeffhaskins's Avatar
    In bootloader you should see fastboot below hboot. Select it and then plug in your device. It should say fastboot usb. Next you need to decide if you want to flash stock firmware or flash twrp recovery and use twrp to flash a custom rom.
    chcgebara likes this.
    12-09-2016 02:20 PM
  8. jeffhaskins's Avatar
    It looks like they have an official CM11 for it. If it were me, I'd flash twrp and then install CM11 from recovery. Once you get it booting and working fine you should be able to go back to stock easily if you want to.
    chcgebara likes this.
    12-09-2016 02:28 PM
  9. chcgebara's Avatar
    Thank yo again jeffhaskins !!!
    You have no idea how desperate I am !

    Just remember that my HOX is International model. Don´t know if it is relevant at this point.
    Bootloader says S-On.
    Additional info on bootloader screen:
    Endeavoru PVT Ship S-On R1

    When connect the USB cable between notebook and HOX, the Fastboot USB appears.
    I understand that there is connection but believe drivers are missing ´cause when I connect and type "adb devices" no HTC infos come up.
    You mentioned "flash stock firmware or flash twrp recovery and use twrp to flash a custom rom".
    Does Stock firmware means an original ROM ? Does TWRP a package to help flash ROMs, etc ? Is it necessary or just a userfrendly front ?
    What do you recommend me ?

    Tks, Cássio
    12-09-2016 02:41 PM
  10. jeffhaskins's Avatar
    Yes stock is the original ROM. TWRP is a custom recovery image that allows you to make changes to the /system partition even though you are s-on(which is system write protection). In the sdk tools where adb is you should have fastboot as well. Here is CM11 and CM recovery if you don't like twrp. https://download.cyanogenmod.org/?device=endeavoru
    Here is twrp recovery https://twrp.me/devices/htconexinternational.html

    Download either recovery (i prefer twrp) and cm11. Next put the recovery.img in the same folder as your adb and fastboot. Rename it to recovery.img to make it easier to type in cmd. Enter fastboot mode, plug in the phone, open a cmd window and type fastboot flash recovery recovery.img. It should do its thing. Move CM11 to root of sdcard. Next scroll down to recovery and boot twrp. Select install and then select the cm11 zip and when finished factory reset and it should boot.
    chcgebara likes this.
    12-09-2016 02:53 PM
  11. chcgebara's Avatar
    Tks jeffhaskins !

    Where can I find SDK Tools ? Do I need to download the complete bundle (Android-studio-bundle) ?

    "Move CM11 to root of sdcard. Next scroll down to recovery and boot twrp. Select install and then select the cm11 zip and when finished factory reset and it should boot."

    I didn´t understand these steps.
    All of them are made using TWRP, right ?
    Which is the ROM ? CM11 ?
    How about drivers ? Just SDK package allow the connection ?
    There is no HTC drivers showed on Windows Device Manager.

    Tks again !
    12-09-2016 04:55 PM
  12. jeffhaskins's Avatar
    You don't need all sdk tools. Just fastboot. You'll have to take your sdcard out and use a card reader or another phone to put the cm11 zip file on the sdcard. By the root of it i mean not in a folder. The root directory. Then you'll put it back in the phone and in bootloader mode scroll to recovery and click it to boot to twrp. (this is of coarse after you've flashed the recovery image.) Then in twrp select install. Select your cm11 zip file. If using twrp you will then swipe to install. Once it's finished hit the home button in twrp and then select wipe. Swipe to factory reset. Then reboot and it should boot. It may take several minutes the first boot.
    chcgebara likes this.
    12-09-2016 06:22 PM
  13. chcgebara's Avatar

    Now I understand the procedure.
    Where download a good fastboot
    As far as I know, HOX doesn´t allow sdcard or battery access.
    Do I need to open/disassembly the mobile to access it ?
    HOX still not connecting with Notebook.
    Which driver can I install ?
    Tks again !
    12-09-2016 06:36 PM
  14. jeffhaskins's Avatar
    Oh, my mistake. It doesn't have an external sdcard? Well, once you get into twrp either adb or mtp (actually probably both) should work again. Then you can adb push the cm11 zip file from your computer to most likely /storage/sdcard0/ so most likely you want to type adb push (drag and drop zip file into cmd window) /storage/sdcard0/
    chcgebara likes this.
    12-09-2016 06:50 PM
  15. jeffhaskins's Avatar
    Here is a link to an adb and fastboot zip I made for you. Inside is also a cmd window that will open to the right path. Just extract it to a folder and use the cmd window to run your commands. https://drive.google.com/file/d/0B3X...w?usp=drivesdk
    chcgebara likes this.
    12-09-2016 06:59 PM
  16. chcgebara's Avatar

    No mistakes !! You are helping me !
    TWRP downloaded.
    ADBandFastboot downloaded and extracted.
    Adb, cmd, fastboot and TWRP.img on the same folder.
    I have to download a .zip CM11 file, and not a .img, which is a recovery, is that right ?
    The CM11 process is a little confused for me yet.
    Just double checking: after TWRP installed, I need to boot using the recovery TWRP and once TWRP loaded, use Install button to install CM11 that must to be in /storage/sdcard0/ folder (in HOX).
    Does CM11 must to be unziped before ?

    Tks !
    12-09-2016 08:16 PM
  17. jeffhaskins's Avatar
    Yes the rom will be a zip file. CM11 nightly. In bootloader mode, you'll see recovery. Twrp is recovery. (Stands for Team Win Recovery Project)
    chcgebara likes this.
    12-09-2016 08:30 PM
  18. jeffhaskins's Avatar
    First thing is to flash twrp. In bootloader select fastboot then plug in the phone. Rename the img to recovery.img. In cmd type

    fastboot flash recovery recovery.img

    Then still in bootloader mode select recovery. It should boot twrp.
    chcgebara likes this.
    12-09-2016 08:33 PM
  19. jeffhaskins's Avatar
    After you get into twrp select wipe. Then swipe to reset. Then go ahead and reboot. It's possible after a factory reset that your stock ROM might boot. If not type
    adb reboot bootloader then select recovery again to boot twrp again. Then install the cm11 zip file.
    chcgebara likes this.
    12-09-2016 08:40 PM
  20. chcgebara's Avatar
    TWRP Installed !!!!!!
    Wiped, swiped to reset, reboot to factory reset.
    I´m on the screew "Reboot SuperSU Check"
    " Your device does not appear to be rooted" (which means the root process that I tried and F...my HOX doesn´t work).
    "There is a question: Install Super SU now ?
    This will root your device"
    The options are Do not install and Swipe to unlock.
    As far as I understood, the root process brings me the SU "benefits", like delete/remove appsinstaled "by factory". Is that true ?
    What do you recommend ?
    12-09-2016 08:57 PM
  21. jeffhaskins's Avatar
    Its your choice. I would make read write. After you make your very first backup. It will ask you if want to root. If you do... let it.
    This is if still on stock rom. CM11 has root. I would, before installing cm or factory resetting, select backup. Then select only the boot.img (to save space) let it back up. When it's done it should ask if you want to root. If yes, let it. Then do a factory reset and see if the stock rom will boot.
    chcgebara likes this.
    12-09-2016 08:59 PM
  22. chcgebara's Avatar
    I choosen Swipe to unlock.
    It was very fast...then appears another screen almost same to the previous. I though it was the same and then swiped again but it sounds that it was an instalation of root process or something like it. White screen again...
    Should I restart ? The whole process ?
    12-09-2016 09:14 PM
  23. jeffhaskins's Avatar
    Ok so i think you are now read write with twrp. Boot back into twrp and wipe data. Then reboot system. If it still hangs, boot twrp again and install cm11. I'm kind of hoping to get your stock rom working too, but if not hopefully cm will boot. Then you can get online and find a zip or backup to get back to stock. (If you don't end up liking cm)
    chcgebara likes this.
    12-09-2016 09:19 PM
  24. chcgebara's Avatar

    The HOX is not on my File explorer, just the drivers C:\, etc.
    How to flash the CM11 or transfer the zip file to HOX in order to install it ?
    12-09-2016 09:34 PM
  25. chcgebara's Avatar
    Hello everyone,

    I would like to thank Jeff Haskins for all the support and patience in helping me with my HOX !
    It was days when we looked at the dawn, looking for alternatives to the correct stock ROM, custom ROM then finally Gapps and configurations, many command lines, etc., and lots of learning...

    Thank you Jeff!
    12-17-2016 10:27 AM
27 12

Similar Threads

  1. Can i root a supersonic sc813 ???
    By Bobby Burress in forum Ask a Question
    Replies: 4
    Last Post: 12-27-2016, 04:57 PM
  2. HTC
    By Jacka1 in forum HTC One M8
    Replies: 1
    Last Post: 12-09-2016, 12:46 PM
  3. S4 stuck at boot
    By paulsto52 in forum Samsung Galaxy S4
    Replies: 1
    Last Post: 12-09-2016, 10:44 AM
  4. do not disturb not fully working
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 12-09-2016, 10:15 AM
  5. Fingerprint not recognized
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 12-09-2016, 10:10 AM