1. AC Question's Avatar
    I have a 16GB Class 8 Kingmax micro SDCARD fat32. The card is corrupted. I tried to format it on android device and computer but it will eject with 0%imcomplete format. When i inserted the card into phone or computer, it shows the files and folder but when i open the files, my phone starts hang and the sdcard automatically eject. The sdcard cannot be read and edited(formatted). Any ideas?
    12-14-2016 10:45 PM
  2. Golfdriver97's Avatar
    Welcome to the forums. Can the formatting happen on the PC or no? It may be possible there are some bad sectors in the card preventing this from happening.
    12-14-2016 11:04 PM
  3. Jason1357's Avatar
    Still same. I have tried several times to format the card with pc or android but it keeps ejecting.
    12-14-2016 11:14 PM
  4. ManiacJoe's Avatar
    Sounds like there might be a problem with sector #0 on the card. This is the one sector that cannot be worked around when it goes bad.
    12-15-2016 12:07 AM
  5. Jason1357's Avatar
    12-15-2016 03:17 AM