06-26-2019 11:51 AM
108 1234 ...
tools Reply
  1. jeffhaskins's Avatar
    One thing seems to be certain, it is definitely a Samsung issue reading through this thread. Those of you that are able to, try flashing CM or or some other AOSP ROM and see if the issue goes away.
    12-30-2016 01:57 PM
  2. henryw48's Avatar
    I don't think so Jeff. I've seen reports for the same problem on Droid and HTC. To me, it is a recent update to some app OR there's something going on in the network.
    12-30-2016 02:50 PM
  3. henryw48's Avatar
    Some other observations.

    In addition to the number of sockets increasing, I've also noticed that the "ps" command is showing that the amount of memory being used by the mdnsd is slowly increasing. As I had said earlier the number of dropped packets is increasing. Given the two, am wondering if mdnsd is having trouble keeping up with the traffic, possibly because it is extracting information from the packets and saving it. Hope it is not doing a linear search through a table of values to find a place to save it. More GUESSing. With some recent (November, beginning of December) updates to some apps, there is more UDP traffic being transmitted and received. All of the sockets that have Recv-Q are owned by mdnsd.

    Without knowing the processing power of the other devices that are having this problem, I might GUESS that some of these devices might be obsolete in that they are too slow and cannot keep up with the increased traffic demands. This is just a GUESS, although it is a way of planned obsolescence. My Samsung Galaxy S3 is over 4 years old.

    I also have a Samsung Galaxy Tab S that has no phone and therefore no mobile data. It just has WiFi. It is much faster and does not exhibit the problem. One of the tests I had performed earlier was to turn off mobile data on my phone to see if I still had the problem. I still did. Likewise, I had turned off WiFi and left mobile data on. I also still had the problem.

    12-30-2016 03:02 PM
  4. nalsawadi's Avatar
    Goodness, finally a thread discussing this problem without mentioning firefox. I've had this problem appear a couple of weeks ago on my Galaxy Note 2. I do not have firefox, nor do I have any drone apps, and my GPS is always turned off, yet MDNSD is eating up my battery even more than the screen is !

    I factory reset my phone and after 8 days MDNSD is back ! I'm starting to suspect this is chrome related? Because I usually use the main android browser, but as soon as I used google chrome (today) the MDNSD appeared back.
    01-01-2017 03:38 PM
  5. BlueDragon123's Avatar
    Henry, have you had any luck with your further research? I have been having this same issue for a few weeks now. I read in another forum that the Mdsnd issue could be related to security software. I had downloaded CleanMaster and then uninstalled it a few days later, that is when the Mdsnd issue appeared. I can get it to stop temporarily by shutting off my phone at night while charging it but as soon as I turn on my location to use Google Maps, it comes right back. It has also reappeared when I did not turn on locations. I am getting quite frustrated. I was also told hackers can use it for identity theft but I have not read anything about that online. I appreciate the depth and time you are putting into figuring this out. I am not a techy and don't have adequate working knowledge of cell phones to get this solved without assistance.
    01-02-2017 05:15 AM
  6. Feli Hadiyono's Avatar
    In my case, i found that the facebook app (version 100++) was the problem. Downgrade to version 90s and restart the phone then the mdnsd gone
    01-02-2017 05:30 AM
  7. BlueDragon123's Avatar
    How do I get a downgraded version?
    01-02-2017 02:11 PM
  8. Feli Hadiyono's Avatar
    How do I get a downgraded version?
    First, uninstall the fb version 100++. Find your friends who use the version 90++ fb app then transfer the app use ShareIt
    01-02-2017 04:09 PM
  9. henryw48's Avatar
    Hello BlueDragon. I have not made any progress in finding out what changed and is causing my problem. I don't think it is Facebook. I had taken Facebook off my phone when I had started using it on my tablet many, many months ago.

    As I had said in a previous reply, it COULD be (A GUESS) that the updates to some apps have started using more and more CPU processing power, making it so mdnsd or some downstream process cannot keep up with bursts of traffic coming into the phone, thus causing the dropped packets. It would also mean that my old phone is obsolete.

    One thing I've noticed with this problem is that everyone appears to have started having the problem a few weeks ago. In my looking at several possible apps, I noticed that there had been a flurry of app updates that came out in the last week of Nov and beginning of Dec. I suspect that that was in preparation for going on vacation or the rush of holiday phone/tablet purchases. I had tried uninstalling several of these, but to no avail.

    Right now, I just downloaded an app to display the log, in hopes that there may be a clue there. However, I'm not hopeful. I now need to learn to understand the log contents.

    In the future, I might develop a monitoring program to try to report when it sees this activity, so I have a better chance of pinpointing the approximate time when an event occurs. It will make it easier to find things in the log or in a network traffic capture.

    Any assistance with more information or finding this problem would be appreciated. This includes the success and/or failure of any attempts.
    01-02-2017 08:54 PM
  10. Huku's Avatar
    Hey guys,
    I've been watching this thread regularly for a while, but just yesterday I made an account so I can post and be part of solving the mdnsd issue.
    My observations are that after an update (I updated about 20 apps at 24.12) any of the apps that I updated makes mdnsd go into endless loop.
    So I started to uninstall different apps that are most suspicious. So far I don't have success.
    However I think that it would be very helpful if we try to find what are the apps that are common for all of us.
    For example - does any of you have the Ping&DNS app installed?
    Another observation I made is that when I kill mdnsd, Viber stops loading media - so currently I am without viber to check if this can be the problem. So far for the last 20 hours I don't experience the mdnsd high cpu problem.
    Unfortunately meanwhile Ping&DNS app updated itself (I had the autoupdate turned on for a while :-( ) and now there could be two reasons. However I want to wait for at least one more day before I confirm that mdnsd problem is solved.
    Meanwhile can you please check if you have this Ping&DNS app installed.
    01-03-2017 05:09 AM
  11. Huku's Avatar
    Well... the mdnsd problem is back again :-( It started heating the CPU during a skype call.
    So, it's not Viber.
    But it's not also skype, because I already removed it a few days ago and the problem still was there.
    01-03-2017 08:32 AM
  12. henryw48's Avatar
    Hi Huku. Thanks for your suggestion and status update! Yes, I also have Ping & DNS. I also noticed that it was just updated again yesterday to version 2.9.3.

    Instead of waiting for the high CPU problem to show up, I've been looking "under the hood" so to speak by using Terminal Emulator or using a language like Python to get at the underlying Linux commands. I'm NOT rooted, so that limits what I can do somewhat, but there's a lot of information anyway. As I've posted, I've been watching the creation of UDP and UDP6 sockets using port 5353 (multicast DNS port) either with netstat command or "cat /proc/net/udp6" and "cat /proc/net/udp". I know there's still a problem when I see more than a few and they have a non-zero RECV-Q.
    01-03-2017 10:27 AM
  13. Huku's Avatar
    It is not very likely that Ping&DNS app causes the problem but I just removed it to test.
    Yeap, I saw your method but for me it's easier just to use top -m 5 and check the top 5 apps that are using the cpu.
    Does anyone else use Ping&DNS app ?
    01-03-2017 01:26 PM
  14. henryw48's Avatar
    Wasn't sure which of the Unix/Linux commands was on the Android. Top is a good way of seeing he problem once it starts looping. However, I detect the problem often hours before it starts looping and by restarting when enough sockets are open, I avoid going into the loop and losing battery time. But yours is a good way of detecting the loop.
    01-03-2017 07:55 PM
  15. Huku's Avatar
    Nice, I understand - going to try this. How many connections are indication for the problem? I wonder if there could be a script that checks from time to time and gives notification when the number is high. Probably Tasker could do that but not sure how.
    01-03-2017 11:29 PM
  16. 57kevin's Avatar
    One thing seems to be certain, it is definitely a Samsung issue reading through this thread. Those of you that are able to, try flashing CM or or some other AOSP ROM and see if the issue goes away.
    Issue not just samsung. I am using sony z3v and am having the same issue. I can usually use avast mobile security to clear my ram and stop apps and it had gone away for a bit in the past but always returns.
    01-04-2017 04:07 AM
  17. henryw48's Avatar
    @Huku: On my phone, when I add up the number of sockets that are UDP plus the number that are UDP6, the mdnsd process starts looping when the resultant number is around 550. I'm in the process of writing a python script to display the total and the time that it was first detected. I could have written a sh script to do that, but I chose python as I'm trying to learn that language.

    @alexdiazaldas73: You say you have a rooted phone with the problem. I have looked at displaying the system log. However, it appears that I can only display log entries for the process associated with the app that I'm using (Terminal Emulator == androidterm). To get more information I would need to root my phone.

    If you are still reading this thread, or if someone else has a rooted phone with this problem, I am hoping the log entries associated with the mdnsd process may have interesting information hopefully showing why it may be failing. All the hundreds of UDP and UDP6 sockets on port 5353 are associated with the mdnsd process.

    Go to a sh prompt. Run:

    ps | grep mdnsd

    The output on my phone is

    mdnsr 4645 1 1588 1004 ffffffff 00000000 S /system/bin/mdnsd

    The first number (4645 in this case) is the process ID of the running mdnsd process.

    Now, become root and run:

    logcat -v *:I | grep <process id from above>

    After a period of time, do a CTRL-C to break out.

    Let me know if you see anything worthwhile.
    01-04-2017 04:07 AM
  18. baronv's Avatar
    I'm on a Nexus 5 (2013) and this issue started happening to both my wife and I today. I know our phones updated some apps last night which is probably the root of this issue.

    Is there a way to sort in Google Play to see which apps were recently updated from the past 3 days? Right now when I checked there's no way to sort it and the "Recently updated apps" section only shows the Twitter app that auto-updated just a few minutes ago.

    Only noticed this issue when I received an email from my wife where her battery drained down to 40% after just 2 hours in stand by and when I checked my own phone it went down from 100% to 40% as well in an hour.
    01-04-2017 11:30 AM
  19. henryw48's Avatar
    On both my Samsung devices, after Google Play updates apps, it puts them in a Recently updated section in the Google Play => Apps & games => My apps & games page for about a week.

    If an app doesn't appear there, could you be using apps not in Google Play that get updated differently?

    The other possibility is that there is something happening on the network that both you and your wife get on that is causing the problem. Once mdnsd enters the loop and starts using the CPU and draining the battery, it doesn't stop until you restart the device.
    01-04-2017 12:38 PM
  20. baronv's Avatar
    I've rebooted my phone already and charging it, and after uninstalling Twitter going to see if the drain happens. My wife's battery drain happend to her while she was at work and mine occurred during my drive into my job, our network is Tmobile. I use Amazon apps too but haven't had to update an app on it in weeks, and my wife doesn't have Amazon Apps installed on her phone. So far it's either a shared common app or the TMO network I'm guessing.

    Weird thing is her battery drain shows the MDNSD as a culprint while my system info did not show it at all and all the running apps appeared normal with only screen activity showing the highest use of the battery.
    01-04-2017 01:42 PM
  21. Catzclub's Avatar
    I think I figured it out for my phone at least. I think mdnsd is linked to micro SD cards. It has something to do with the memory on them, I transferred all my SD card data to my laptop and then proceeded to reset the sd card and put it back in my phone. Throughout the time I did that I let my phone go from 100 to 0 and used it the whole time, mdnsd never appears. I then put the SD card back in and bam, while it was charging I see mdnsd pop right back up again. I have an LG G3, with Verizon. So hopefully this helps someone.
    01-04-2017 09:54 PM
  22. Huku's Avatar
    @henryw48 : my phone (Galaxy S5) is rooted and I have terminal, so it's not a problem to run the commands you wrote above. But I guess that would make sense only when the problem appears, right?
    @baronv: I had the same problem and the best way I found to check the date when the apps are updated is with ES File Explorer - inside it there is menu "App" where you can see all your apps and the update (modified) dates.

    And one more thing - as I said earlier I have uninstalled Ping&DNS on 03.01.2017 and luckily the problem didn't appear since then.

    I wonder if SD card has really something to do with this problem as suggested by Catzclub...
    01-04-2017 11:59 PM
  23. henryw48's Avatar
    Thanks to all those who submitted suggestions and what they did to try to fix problem. I can see that it affects devices on multiple carriers. I am on Verizon and am using wifi connected to Comcast (Xfinity), so the problem diesn't appear to be carrier specific. It can still be caused by the traffic geting to the phone over different services.

    I also have a Samsung tablet. I checked and found that although it still had the /system/bin/mdnsd program, it wasn't even running. So there might be a set of programs that need it. Unfortunately, I don't know what those programs are or what in the configuration starts it.
    The reply about the possibly being related to the SD card is interesting. I have several apps with data and / or executables on my SD card. Typicallty SD cards are slower and so it MAY be causing the device to run more slowly causing the backup on the recv-queue.

    @Huku: Thanks for offering. Yes you would need to see it happening. However, if the number of sockets on UDP port 5353 is increasing, that's the period from which we might see something in the log. You don't have to see the mdnsd looping to capture good data. More importantly, the messages needed may be right before the mdnsd process goes into the loop. The logcat program can be set up to run and log the results in a file continuously.
    01-05-2017 02:59 AM
  24. henryw48's Avatar
    @Huku: Thanks very much for your suggestion about checking out Ping & DNS. I just removed it last night and it appears to be the culprit in our cases. Looking on the Google Play site, I see that there were numerous complaints about a new feature called NetSentry that monitors network interface traffic. People tried to turn it off and couldn't. Supposedly the author has fixed the problem as of the 1/2/2017 release. However, whether it is fixed or not, it did not fix our problem. I had the latest release on my phone and the socket count problem was still there.

    I have Ping & DNS on my tablet also, but don't have the problem. It is only on the Samsung Galaxy S3 phone. That might be because the phone is old and the latest Android kernel that Verizon and/or Samsung has released for it, is the 4.4.2 (KitKat) version or as I had said earlier, the old phone may not be able to keep up with the work.

    In either case, as soon as I had removed the Ping & DNS, I noticed that the number of UDP and UDP6 sockets for port 5353 had stopped growing. When I rebooted, the "mdnsd" process was not running any more and the number of UDP sockets for port 5353 was just 1 or 2. It has been many hours, and by now, the number of sockets would have grown. So I consider this problem resolved for me (unless of course it reappears, which I don't expect).
    01-06-2017 12:14 PM
  25. Devils Advocate1's Avatar
    My wife solved the mdnsd problem on her Droid today by removing the "WeatherBug" app.
    01-07-2017 12:05 AM
108 1234 ...

Similar Threads

  1. How to reinstall Lollipop 5.1 on infected phone
    By AC Question in forum Ask a Question
    Replies: 6
    Last Post: 02-05-2017, 09:10 AM
  2. Bluetooth stopped working on Google maps
    By srfoot in forum Samsung Galaxy S5
    Replies: 2
    Last Post: 12-23-2016, 08:33 PM
  3. Replies: 2
    Last Post: 12-22-2016, 04:54 AM
  4. Can i use my galaxy j7 with your service
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 12-21-2016, 05:46 PM
  5. Replies: 0
    Last Post: 12-21-2016, 05:38 PM