1. AC Question's Avatar
    I broke the screen on my S4, but have an old one so I figured I would just swap the SIMs and carry on my way. However, my phone contacts were lost in the process. Thankfully I was able to swap the motherboards and everything turned out okay, but I'm a little mad because Google could have screwed me big time by not syncing my data.

    Under "Accounts" in Settings, both my Google accounts are listed as "Last synced"...today. When I click on both, everything is checked (e.g. Sync App Data, Sync Contacts, etc.). What gives? Is this the wrong settings menu?

    Any help would be appreciated, I got lucky this time and would very much like to prevent this in the future
    01-08-2017 10:30 PM
  2. jeffhaskins's Avatar
    Did you store them as google contacts? Usually when adding a contact it will ask you phone or google. The ones that you pick phone on don't store to google and therefore can't sync to you account.
    chanchan05 and B. Diddy like this.
    01-08-2017 10:50 PM
  3. B. Diddy's Avatar
    Welcome to Android Central! What jeffhaskins mentioned is extremely important. Only the contacts you save to your Google account will sync automatically to your Google Contacts in the cloud -- this is why I always strongly recommend that people do this, rather than saving them to the local Phone account (which doesn't sync anywhere -- you have to manually back them up).

    You can easily tell if your contacts have synced to your Google account by going to contacts.google.com on your desktop browser and looking for them there. You can see which account your contact on your phone is associated with by opening your Contacts app, selecting the contact, and looking near the top of the contact card.
    01-09-2017 12:59 AM
  4. chanchan05's Avatar
    Since you're using a Samsung, it's best to sign into a Samsung account as well if you are averse to saving to Google. Samsung accounts sync to cloud the non-Google contacts on the phone.
    B. Diddy likes this.
    01-09-2017 02:11 AM
  5. AlphaTango414's Avatar
    B. Diddy and used above has the valid point of why your contacts probably were not backed up by Google. I wish android would make it default for them to be saved as Google contact and not local on your device.
    Since you're using a Samsung, it's best to sign into a Samsung account as well if you are averse to saving to Google. Samsung accounts sync to cloud the non-Google contacts on the phone.
    Very good point. I actually prefer my Samsung account backups to my Google. However, I only have Samsung products for the past 4-5 years. Going to another manufacturer would make my Samsung backups a lot less helpful.
    B. Diddy likes this.
    01-09-2017 02:46 AM

Similar Threads

  1. I am unable to change my security setting from pin to none
    By Prakhar verma in forum Android 6.0 Marshmallow
    Replies: 8
    Last Post: 01-14-2017, 07:41 AM
  2. Why can't I retrieve copies from my clipboard
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 01-09-2017, 01:04 AM
  3. How do i unlock my cricket s7 with a sprint sim card in it?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 01-09-2017, 01:02 AM
  4. Why is my Note 5 home button now my power button?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 01-08-2017, 11:17 PM
  5. AT&T Address Book sync issue
    By Kalvin Kerns in forum Samsung Gear S3
    Replies: 0
    Last Post: 01-08-2017, 09:35 PM
LINK TO POST COPIED TO CLIPBOARD