1. QuantumChris's Avatar
    Okay so recently my Dad purchased a samsung fast charger for me he said It worked perfectly fine on his s7 but when I looked at it and researched a bit i quickly realized he bought a fake fast charger but he said it was fine. I used it one night and I used my phone perfectly fine all day I didn't see anything wrong with like battery draining extra fast but I did have a long day so I brought my other charger i usually used a slower one that charged my phone perfectly fine so i charged it up a bit then i used it and it died after charging it from 10% to 17% but it the battery drained pretty normal as it was a 30 minutes bus ride for a audition i needed to do after school. I plugged in my normal charger into a wall and it charged the entire time while i was at my 1 and a half hour audition. When i was finished i checked my phone and i just clicked the power button to check battery percentage and it was at 78% so i unplugged it and tried to turn it on but then it stop responding and i plugged it back in and there is no indication of charging I've tried every button to restart and do whatever with the buttons and nothing works and nothing displays on my screen I tried to charge it and everything nothing is working or responding I'm really upset because it's such a great phone the only thing I know that it is at least getting some sort of power is when i charge it my phone heats up I don't think there is anything I can do but if someone can preform miracles i need one I went to a samsung repair shop they were certified and such and they said they can't do anything with unwarranty phones because they are focusing on note 7 issues at the moment and basically any sort of hardware repair is impossible because of the water tight seal would never be resealed so I can really get it fixed but maybe there is someone out there that could help me out.
    01-10-2017 10:41 PM

Similar Threads

  1. Alert slider broken. Stuck on to not disturb.
    By MrScottah in forum OnePlus 2
    Replies: 4
    Last Post: 01-12-2017, 01:28 AM
  2. Replies: 1
    Last Post: 01-11-2017, 02:34 AM
  3. I cant open set up wizard on my O+
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 01-10-2017, 10:39 PM
  4. Replies: 0
    Last Post: 01-10-2017, 10:08 PM
  5. Replies: 0
    Last Post: 01-10-2017, 10:05 PM