1. AC Question's Avatar
    I have a Samsung Galaxy Note Tab 3 (8") that is running 4.4.2; it's a few years old. I recently purchased a GetFit2.0 X64 fitness band that runs with the app GetFit2.0 or VeryFit 2.0. Both apps which the fitness band requires are said to be compatible with Android 4.3+ OS.

    However, when I try to download either app, it's saying my "device is not compatible". Would a fix be to try to revert my tablet back to the 4.3 OS? Is this even possible?

    I'm sorry if this is a silly question... I don't know too much about tablets and their inner workings. I would just really like to use this new fitness tracker/band and it looks like it's a no-go with my current tablet. My husband owns a relatively new Samsung Galaxy Tab A and he cannot download the apps either.

    I would really appreciate any suggestions/info!
    01-19-2017 07:06 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! It's likely that the tablets lack some of the sensors that are required for this kind of app. Either that, or the developers only intended the app for phones, and not tablets.
    01-19-2017 08:17 PM

Similar Threads

  1. I need to reset my password
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 01-19-2017, 08:40 PM
  2. Replies: 1
    Last Post: 01-19-2017, 08:31 PM
  3. Replies: 1
    Last Post: 01-19-2017, 08:28 PM
  4. Will the note 5 case fit the note 4
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 01-19-2017, 08:21 PM
  5. Galaxy s4 Odin problem..at wits end!
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 01-19-2017, 06:37 PM
LINK TO POST COPIED TO CLIPBOARD