1. cjsab504's Avatar
    Lately, after a download reaches 100%, my Play Store app just sits there, still saying "downloading", and goes no further. The "Open" button never does appear. Sometimes the install actually does succeed, but only after an interminable wait, and only in the background, never reaching the point of displaying the "Open" button or otherwise offering any sign that the installation really did complete.

    I was tinkering with my boottime selection of startup apps and services recently (phone is rooted), and clearly I disabled something that the Play Store and/or the package installer depends on, but I could really use a hint as to what to look for (and where!). Or is there a file containing a task list or something that needs to be cleaned up or deleted?

    What's most odd is that the install actually succeeds eventually (usually, anyway; hard to say what the probability of success might be, since I haven't tried it enough times to really say). It seems that Play Store transfers control to the package installer, but control is never handed back to it, and regardless, the install takes forever to complete.

    Does anyone know the dependencies for Play Store and the package installer, or how to go about finding them out?

    I thought of just reinstalling both Play Store and the installer, but can't even find the Play Store app, and not at all sure which of the many installers available I should get.
    Running Android 5.1 on a Coolpad Catalyst. Any advice will be *so* very much appreciated!

    Thanks in advance.
    01-30-2017 10:48 AM
  2. cjsab504's Avatar
    A small correction/addendum:

    An app whose installation I had begun a few hours(!) ago finally finished, and control did return to the Play Store app. So I think that may narrow the problem down to the installer, although it is unusual that the Play Store screen still doesn't change at all while the actual install is taking place. No "Installing..." message or anything. Very mysterious!

    Anyone have a clue to offer? Thanks!
    01-30-2017 01:21 PM
  3. pkcable's Avatar
    Have you tried rebooting the phone? Also try clearing the cache from the Google Play Store, and if that doesn't work clear the cache from Google Play Services, and finally as a LAST resort clear DATA from those 2, BUT that has consequences. Such as you have to sign in to your account all over again.
    01-30-2017 01:38 PM
  4. cjsab504's Avatar
    Good idea! I'll give that a shot (why didn't *I* think of that?). โ˜บ

    Thanks! I'll let you know if that helps.
    01-30-2017 02:03 PM
  5. cjsab504's Avatar
    Have you tried rebooting the phone? Also try clearing the cache from the Google Play Store, and if that doesn't work clear the cache from Google Play Services, and finally as a LAST resort clear DATA from those 2, BUT that has consequences. Such as you have to sign in to your account all over again.
    Did all of the above and no change. :-( Damn! I'll keep trying different things, try to verify what's running and what isn't, but I'm running out of ideas here. This is fairly annoying. Wish I knew what I'd done to cause this. May be time to start uninstalling some of these system and boot modifying apps and see if I get lucky. Follow up later.
    01-30-2017 03:19 PM
  6. B. Diddy's Avatar
    My phone isn't rooted, but I do notice sometimes that an app will get stuck at 100%. Sometimes it installs after a minute or so, but when it just doesn't install, it typically works if I go to Settings>Apps, select Play Store and Download Manager, and Clear Cache/Data for both.
    pkcable likes this.
    01-30-2017 05:02 PM
  7. cjsab504's Avatar
    A Happy Ending at last!

    Having tried all of the suggestions posted here without success, I finally decided to try the "Uninstall Updates" option for Google Play Store in Settings/Apps, and voila! Problem solved, back to normal operation once again. Yay!

    Thanks again to all who offered advice anyway. Much appreciated. And hopefully, by posting what worked for me, maybe someone else will be spared the troubles I had for a while there.
    belodion, B. Diddy and pkcable like this.
    02-01-2017 07:26 AM
  8. B. Diddy's Avatar
    Glad it works now -- but be aware that the Play Store typically auto-updates itself in the background, and I'm not aware of a way to prevent that from happening. So the problem might come back. Or maybe the fact that you uninstalled the updates got rid of some glitch that won't return when it gets updated again.
    pkcable likes this.
    02-01-2017 10:05 AM
  9. cjsab504's Avatar
    Glad it works now -- but be aware that the Play Store typically auto-updates itself in the background, and I'm not aware of a way to prevent that from happening. So the problem might come back. Or maybe the fact that you uninstalled the updates got rid of some glitch that won't return when it gets updated again.
    Yes, that did cross my mind, too. I guess I'll just have to keep my fingers crossed and see on that one.
    02-02-2017 05:57 AM
  10. cjsab504's Avatar
    Or maybe I'll just go ahead and update now and see if the problem reoccurs or not. I feel safer now trying that, knowing I can always revert back to the earlier version. Then again, maybe I should just count my blessings and leave well enough alone. You know the old saying: "If it ain't broke, don't fix it!" ๐Ÿ˜Š
    pkcable likes this.
    02-02-2017 06:13 AM
  11. cjsab504's Avatar
    Oh well, no need for that; I see it's already updated itself, and happily, is still working just fine.

    So, as they say, all's well that ends well! ๐Ÿ˜
    B. Diddy and pkcable like this.
    02-02-2017 06:33 AM
  12. pkcable's Avatar
    Oh well, no need for that; I see it's already updated itself, and happily, is still working just fine.

    So, as they say, all's well that ends well!
    Perhaps first time around you got a bad download on the update. In any event I'm glad you got it sorted!
    02-02-2017 01:34 PM

Similar Threads

  1. LG Stylo 2 plus hotspot won't connect to Internet
    By iam144 in forum General Help and How To
    Replies: 7
    Last Post: 01-30-2017, 11:34 PM
  2. How to delete pin on lock screen on samsung galaxy note 5
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 01-30-2017, 05:44 PM
  3. I want to change my lock screen.
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 01-30-2017, 12:14 PM
  4. I am not able to had another home page on my s7
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 01-30-2017, 10:36 AM
  5. What Android Cameraphone are you looking forward to in 2017?
    By Diehlirious in forum Ask a Question
    Replies: 0
    Last Post: 01-30-2017, 10:00 AM
LINK TO POST COPIED TO CLIPBOARD