1. AC Question's Avatar
    I have an unlocked Nexus 6P -- bought directly from Google -- running the Android 7.1.2 beta. Android version 7.1.2, security patch level March 5, 2017, baseband version angler-03.81.

    I am trying to copy mp3 and m3u files to my phone and play them with a music player.

    From my research, I believe that Google Play Music may no longer support m3u files, so let's ignore them for the time being.

    When I copy mp3 files into subdirectories of /storage/emulated/0/Music, Google Play Music doesn't recognize that they're there. Pulsar doesn't recognize that they're there. BlackPlayer doesn't recognize that they're there.

    I tried installing and running the media Re.Scan app to rescan the files. It appears to work, and the amount of storage space consumed by the Media Store app increases, but none of the apps acknowledge the existence of the mp3 files even after the rescan.

    Restarting the phone doesn't help. Clearing storage for the Media Store app and _then_ restarting the phone doesn't help.

    The apps won't acknowledge mp3 files regardless of how I put them onto the phone. I tried MTP, I tried adb push, I tried Downloading them over the internet. None of it works.

    The files are visible in adb shell and visible to Astro File Manager. When I browse to one of the files in Astro and open it, Google Play Music plays it. If I plug the phone into my Linux computer and mount it via NTP in Nautilus and browse to one of the mp3 files and double-click on it, it plays. So clearly the files are actually there on the disk and not corrupt.

    I've tried everything I can think of. What am I missing?
    03-28-2017 05:06 PM
  2. jikamens's Avatar
    I figured it out.

    Somehow I ended up with a file /storage/emulated/0/.nomedia.

    I think the Synology DS Cloud application created it when I accidentally briefly told it to sync my CloudStation drive to /storage/emulated/0 instead of /storage/emulated/0/CloudStation, and then I failed to notice the .nomedia file and clean it up when I cleaned up the bad sync.

    So, PEBKAC problem. D'oh!
    03-28-2017 06:28 PM

Similar Threads

  1. Replies: 3
    Last Post: 03-28-2017, 09:55 PM
  2. Why isn't my device connecting to SideSync?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 03-28-2017, 08:06 PM
  3. Replies: 2
    Last Post: 03-28-2017, 05:38 PM
  4. messenger app - nougat
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 03-28-2017, 04:50 PM
  5. Replies: 0
    Last Post: 03-28-2017, 04:50 PM