1. AC Question's Avatar
    I recently rooted my device. After many errors and even a bricked device, I finally managed to root the device and unbrick it. The opperating system was deleted in the process along the way and I had to flash a stock ROM onto the device, resulting in a downgrade from 6.0 to 5.1.1. I still had TWRP on the device and was able to put the needed superuser zip files on the SD card when in TWRP mode because that's the only time the pc recognized the phone. After install in the Superuser files in Twrp the device rebooted up and I ran a root checker and it says that superuser was installed correctly and I have root access. Now here's the issue, I went to go and turn on unknown sources and when I click on fingerprints and securiry, I'm met with an error message saying com.android.settings has stopped . this happens In a few other areas of the settings but not all. I also had downloaded another app (MY Hidden Settings) that I was hoping would allow for me to turn on unknown sources and when I click on the option to turn on unknown sources, I get anmessage saying system/bin/su missing. I now am lost and have no idea what to do. I tried copying a file named su from the xbin folder thinking that may fix the issue but it didnt. Any tips or ideas? If I have to unroot the device and reroot I have no problem doing so (although I'd probably need a concise tutorial because I had very poor luck getting as far as I did..)
    04-02-2017 09:43 PM
  2. smvim's Avatar
    Sounds like the file system itself is messed up and you need to get your device re-flashed with the correct stock ROM, check that everything is working again, then afterwards root it and install a custom ROM.
    But please state what phone or tablet you have and which carrier. Without more details it's difficult to go any further.
    04-02-2017 11:38 PM

Similar Threads

  1. No "system previews" in the status bar on Samsung Galaxy Note 4?
    By AC Question in forum Samsung Galaxy Note 4
    Replies: 3
    Last Post: 04-04-2017, 04:40 PM
  2. system UI crashes when screencapping
    By j2xv in forum Samsung Galaxy S6
    Replies: 6
    Last Post: 04-03-2017, 07:28 AM
  3. LG G6 system resever size?
    By AC Question in forum LG G6
    Replies: 3
    Last Post: 04-02-2017, 05:55 PM
  4. Replies: 0
    Last Post: 04-02-2017, 04:15 PM
  5. LG G6 system resever size?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 04-02-2017, 11:55 AM