1. Cooldawg101's Avatar
    I have an SCH-I545 (Version S4) and I have had it for a few weeks. I had lost my charger so i used a spare one from my other phone connected to my Chromebook. after it charged very slowly (About 2% every 10 minutes) I decided to switch it to a wall charger, to which it stayed at 20% for an hour. I decided it would be the best of interest to restart my phone to clear up anything that may be draining power, assuming that was the issue. I attempted to turn it on after turning it off... but there is no signs of life? I bled it and it still didn't work... left it off for a few hours nothing... so I tried to let it charge overnight, it did get hot after a little... but no signs it wants to boot. I took the battery and put it into an AT&T version of the phone and it charged... so it isn't the battery. the LDI has a bunch of red X on it, but that has been like that even before this happened... I did get the phone used, but it ran perfectly fine. my friend told me the phone does this from time to time, but I want to do what I can to make it run. What can I do to revive this phone? I am assuming that it isn't detecting the battery, and after looking at many forums they suggested to clean the connectors and see if it isn't connecting, but it didn't work.... I can't get it to even turn on, no vibrations or lights anywhere...
    04-08-2017 11:21 AM
  2. B. Diddy's Avatar
    When you put the battery into the other phone, did you only see if it would charge, or did you actually try to power that phone on as well?
    04-08-2017 03:51 PM
  3. Cooldawg101's Avatar
    It did charge and worked fine... Despite being slightly smaller...
    04-08-2017 09:02 PM
  4. B. Diddy's Avatar
    Ok, and just to be sure -- you unplugged the charging cable first on this other phone before trying to power on?

    On the problem phone, have you already tried pressing and holding Power for at least 10-15 seconds to turn it on?
    04-09-2017 12:39 PM
  5. Cooldawg101's Avatar
    Done this all before I bleed it... Then I held for 30 seconds on power alternating charger and none... Held for a while on and off charger ... And many more... I full charged and I killed and charged the battery
    04-09-2017 12:51 PM
  6. B. Diddy's Avatar
    In that case, it could be a problem with your phone's power button or motherboard. You'd have to bring it to a repair shop to diagnose it.
    04-09-2017 03:42 PM
  7. Cooldawg101's Avatar
    I'll see what I can do... For now I have a coffee cup warmer >.0
    04-09-2017 05:44 PM

Similar Threads

  1. Gear S3 Battery drains faster after latest update.
    By lume80 in forum Ask a Question
    Replies: 5
    Last Post: 04-12-2017, 05:06 AM
  2. Replies: 1
    Last Post: 04-08-2017, 04:37 PM
  3. gmail app on S7 edge not working properly
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 04-08-2017, 04:33 PM
  4. Replies: 2
    Last Post: 04-08-2017, 03:54 PM
  5. How can I not accept new update?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 04-08-2017, 10:09 AM