1. AC Question's Avatar
    I went to the google app, went to settings, then went to voice. I tried activating the ok google from any screen but whenever I press the button it says "error retrieving settings, please try again later." I really want it to activate but I don't know how to fix this. Help.
    04-18-2017 11:36 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Which phone? Does this persist after a reboot?
    04-18-2017 12:28 PM
  3. Willow Kitty90's Avatar
    I forgot to log in here. Sorry! Anyways, it does persist after a reboot and my phone is an Alcatel onetouch.
    04-19-2017 12:43 PM
  4. B. Diddy's Avatar
    There are quite a few different One Touch phones -- can you tell us the exact model name/number?
    04-19-2017 03:52 PM
  5. Willow Kitty90's Avatar
    Model number:
    A571VL

    I'm not sure what the model name is
    04-19-2017 05:00 PM
  6. B. Diddy's Avatar
    Ok, try wiping the cache partition, which won't erase any personal data: ALCATEL One Touch 7 Pixi - Recovery Mode - HardReset.info
    04-19-2017 05:11 PM
  7. Willow Kitty90's Avatar
    I tried wiping the cache, it still shows the same error message.
    04-19-2017 06:13 PM
  8. B. Diddy's Avatar
    Which button are you pressing that gives you the "Error retrieving settings" message?
    04-19-2017 06:30 PM
  9. Willow Kitty90's Avatar
    After I go to the settings from the google app, I press ok google from any screen. Then a message pops up with an option of cancel or yes I'm in. When I press yes I'm in it shows the message.
    04-19-2017 09:35 PM
  10. B. Diddy's Avatar
    Strange. This happens on both wi-fi and mobile data?

    Try going to Settings>Apps, select the Google app, then tap Storage, then Clear Cache/Clear Data. Now try again.

    If that doesn't work, you might try going to Settings>Accounts-Google​, selecting your Google account, then Menu>Remove Account. After the account is removed, add it back again.
    04-19-2017 09:41 PM
  11. Willow Kitty90's Avatar
    Thanks! The removing and adding the account back worked.
    B. Diddy and Tobi09 like this.
    04-21-2017 01:50 PM
  12. Tobi09's Avatar
    I have the same problem, and all these did not work for me, i use an infinix hot 3. Please help!
    09-22-2017 08:48 AM
  13. 3rd eclipse di lyricist's Avatar
    The ok Google has stop displayed in the search box how can fix it and i have try downloading the ok Google command but the Google assistant stop it from working.....
    10-14-2018 03:44 PM

Similar Threads

  1. Links Don't Work
    By themagician8 in forum Samsung Galaxy S7 edge
    Replies: 8
    Last Post: 04-23-2017, 09:09 PM
  2. why I can not open my gmail?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 04-18-2017, 12:34 PM
  3. My phone is hacked with malware bootloader how do i remove
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 04-18-2017, 12:30 PM
  4. Replies: 1
    Last Post: 04-18-2017, 12:29 PM
  5. HTC M8: Phone Won't Select Any Items From the Fastboot Screen
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 04-18-2017, 10:27 AM
LINK TO POST COPIED TO CLIPBOARD