1. thomasbihn's Avatar
    I just switched from iPhone to Android and have finally been able to clean up my contacts. In iPhone, I had to go to a contact, selected it, tap edit. Scroll down twice, press delete, press delete again. I had hundreds of useless contacts that would take me all day to remove so I just left them.

    So after I transferred the 1000 contacts over from my iPhone to my Android, I saw that I could actually go through and select then delete them in one fell swoop. I think I removed about 600-700 contacts.

    So now I repeatedly get this message in notifications: "Sync: Too Many Contacts Deleted." When I click on delete, it says it's only deleting 32... All the contacts I deleted in Contacts on the new phone are still deleted.

    It seems it is related to Gmail synchronizing the contacts and all the junk contacts probably migrated up to my gmail account.

    1. Can I delete all the contacts from my Gmail account and have the sync repopulate them?
    2. If so, how can I do this quickly?

    My only other option is to disable synchronizing contacts with Gmail, which I really don't want to do. I'm not going through and trying to pick the deleted contacts in Gmail and deleting them one by one.
    04-23-2017 08:49 AM
  2. jrmeiring's Avatar
    Same problem. I just got the new Galaxy S8, decided to clean up my contacts, and am getting the same error message "Too Many Contacts Deleted." Any help would be appreciated!
    04-26-2017 11:22 AM

Similar Threads

  1. s7 edge keyboard and back button lag
    By Atiq746 in forum Samsung Galaxy S7 edge
    Replies: 2
    Last Post: 04-26-2017, 07:12 AM
  2. Replies: 1
    Last Post: 04-23-2017, 12:33 PM
  3. Why can't I get texts through Bluetooth whilst driving?
    By scotsmiss in forum Ask a Question
    Replies: 1
    Last Post: 04-23-2017, 08:55 AM
  4. Replies: 2
    Last Post: 04-23-2017, 08:31 AM
  5. How to change the contacts screen from white to color
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 04-23-2017, 08:09 AM