1. AC Question's Avatar
    I bought an S8 a couple of days and I have been consistently noticing an issue with WiFi. The phone connects to WiFi router ok, works fine for about 5 mins, and then an exclamation mark appears right next to wireless icon in the notification bar and then the phone says 'connected to xxxx wireless network but no internet', however all the other smart devices connected to the router work just fine

    Factory reset, router reset, static IP assign...tried all nothing helped. Internet speed clocks consistently at 40 Mb so I have no issues with the actual internet coming into my house, please can you help
    04-26-2017 07:41 PM
  2. shandarby's Avatar
    This is also happening to me with my new S8, but more intermittently. Statas changes from 'connected' to 'internet may not be available' seemingly without pattern.

    Other devices connect to the network fine.
    Disconnect other devices and it makes no difference.
    Phone connects to other networks without issues.
    Restart router - no fix
    Disconnect from network. Connect to other network. Forget all networks. Restart phone - no fix

    Very annoying. Would love a fix asap
    04-30-2017 07:55 AM
  3. Saurav Dey2's Avatar
    Hi,
    I have found a solution to this problem.

    1. GO to wifi settings
    2. Forget the wifi network
    3. CONNECT AGAIN BUT BEFORE CONNECTING GO TO ADVANCED OPTIONS AND CHOOSE STATIC INSTEAD OF AUtOMATIC. Enter in the ip address etc and connect. Problem will be solved.
    05-05-2017 11:41 AM
  4. Saurav Dey2's Avatar
    Hi,
    I have found a solution to this problem.

    1. GO to wifi settings
    2. Forget the wifi network
    3. CONNECT AGAIN BUT BEFORE CONNECTING GO TO ADVANCED OPTIONS AND CHOOSE STATIC INSTEAD OF AUtOMATIC. Enter in the ip address etc and connect. Problem will be solved.
    05-05-2017 02:46 PM
  5. The Wonderous Stuart's Avatar
    I'm on the S6 and your "solution" didn't seem to work at all for me.
    05-11-2017 09:29 PM
  6. Rukbat's Avatar
    Entering a static IP address works - until some other device connects and gets that address. then you try to connect the phone and you have two devices trying to use the same address - and it won't work.

    Try disabling IPv6 in the router, instead.
    05-12-2017 02:45 PM
  7. mddolloff's Avatar
    Entering a static IP address works - until some other device connects and gets that address. then you try to connect the phone and you have two devices trying to use the same address - and it won't work.

    Try disabling IPv6 in the router, instead.
    IPV6 was already disabled on my router and still get the problem. So I don't think that is the fix either.

    You could always set the static IP for the MAC address in the router as well, but that seems like a pretty advanced solution for what shouldn't be a problem at all on a phone of this cost.
    06-30-2017 12:14 PM
  8. kg227's Avatar
    I am having the exact same issue on my galaxy tab s2, even on the replacement. Due to the being such an intermittent problem, it wouldn't do it when Samsung support checked it out...

    This happens on both 2.4 ghz and 5 ghz frequency for me. I've tried downloading a wifi fixer, I've reset network settings, and turned off nearby device scanning. I've also tried doing what a forum suggested by changing the ip settings from dhcp to static but it wouldn't connect to wifi at all. Not sure what else to try...

    I read that it may be due to nougat 7.0 software. I was suggested by Samsung to first put the tablet on safe mode (this disables third party apps, and would reveil if an app was causing the problem) but the problem still persists. Also did a hard reset on the first tablet I had but it still done the same problem...
    08-08-2017 06:38 PM
  9. dpomerance's Avatar
    I have the same problem. Seems like when the phone goes to sleep it loses the internet piece of the connection. When you wake the phone up it comes up on 4G if you have Smart Network Switch turned on and then it kicks back over to WiFi. If you have Smart Network Switch turned off for a more stable WiFi, you are just SOL. It is a a FEATURE that Nougat brought with it.
    08-27-2017 09:39 AM
  10. Rukbat's Avatar
    IPV6 was already disabled on my router and still get the problem. So I don't think that is the fix either.

    You could always set the static IP for the MAC address in the router as well, but that seems like a pretty advanced solution for what shouldn't be a problem at all on a phone of this cost.
    The IP address and the MAC address have nothing to do with one another. Putting the MAC address as the static IP address will guarantee that the phone won't connect to the internet.
    Laura Knotek likes this.
    08-27-2017 01:42 PM
  11. Rukbat's Avatar
    See if there's an option in the advanced wifi settings to keep wifi on when asleep. Set it to never turn wifi off - this has been a problem since before Google came out with Android - many wifi adapters will lose the connection if they're turned off, then turned on.
    08-27-2017 01:45 PM
  12. dpomerance's Avatar
    It is set to leave on always
    08-27-2017 02:32 PM
  13. mddolloff's Avatar
    The IP address and the MAC address have nothing to do with one another. Putting the MAC address as the static IP address will guarantee that the phone won't connect to the internet.
    well yes I know that the IP address and MAC address are different things. I was suggesting assigning a given MAC address a static IP rather than dealing with DHCP. I have no earthly idea if this would fix the problem.

    FYI, this problem had gone away for me, but reared it's early head again this weekend.
    08-27-2017 08:08 PM
  14. Doug Moffat's Avatar
    If you have a carrier head back immediately. Do not pass go, do not collect $200.
    08-27-2017 10:34 PM
  15. Kirstein Gourlay's Avatar
    I have the same problem. Seems like when the phone goes to sleep it loses the internet piece of the connection. When you wake the phone up it comes up on 4G if you have Smart Network Switch turned on and then it kicks back over to WiFi. If you have Smart Network Switch turned off for a more stable WiFi, you are just SOL. It is a a FEATURE that Nougat brought with it.
    What does SOL mean? Same thing happens on my Chinese phone. I flip to 4g then back to wifi and it works again.
    08-27-2017 11:07 PM
  16. GatoCat's Avatar
    If your phone is new and you can't get internet, make sure your router allows the device to connect. I got a new S8 and couldn't connect until I remembered that I have the router blocking all new devices and I have to add them manually.
    09-24-2017 02:51 AM
  17. Exclusive28's Avatar
    I had this issue in Samsung J7 Prime and here's how I resolved it.
    Go to Settings and Application Manager. Make sure "All Apps" are displayed. Locate the Settings app, click it and Force Stop it. It will start automatically again, and WiFi worked for me.
    Note that Settings app is system settings app. If you find Clear Data, then that works, too, but for Samsung Galaxy J7 Prime, force stopping the Setting app resolves the Internet Not Available issue.
    11-21-2017 03:05 AM
  18. paulwilko10's Avatar
    I had this issue in Samsung J7 Prime and here's how I resolved it.
    Go to Settings and Application Manager. Make sure "All Apps" are displayed. Locate the Settings app, click it and Force Stop it. It will start automatically again, and WiFi worked for me.
    Note that Settings app is system settings app. If you find Clear Data, then that works, too, but for Samsung Galaxy J7 Prime, force stopping the Setting app resolves the Internet Not Available issue.
    Is this a permanent fix, don't see why it would work, but i'll try anything as it sgetting on my nerves on S7
    12-04-2017 11:51 AM

Similar Threads

  1. Curent Take on Flagship Phones LG G6, Samsung S8 S8+, Google Pixel
    By consultant1027 in forum The Android Central Lounge
    Replies: 5
    Last Post: 06-29-2017, 05:16 AM
  2. Replies: 1
    Last Post: 05-14-2017, 11:47 AM
  3. number on reject list still rings when they call me
    By AC Question in forum Ask a Question
    Replies: 3
    Last Post: 04-26-2017, 08:02 PM
  4. Photo cropping on s8 plus
    By Barrsyboy1 in forum Samsung Galaxy S8 & S8+
    Replies: 2
    Last Post: 04-26-2017, 07:22 PM
  5. Photo cropping on s8 plus
    By Barrsyboy1 in forum Samsung Galaxy S
    Replies: 0
    Last Post: 04-26-2017, 06:57 PM
LINK TO POST COPIED TO CLIPBOARD