1. AC Question's Avatar
    TL;DR: My S6 is freaking out and not responding to some actions; the back button doesn't work; it seems that the back button is being pressed erratically when I'm not touching the phone; I don't know what's happening.

    I've owned my Galaxy S6 for 1 1/2 - 2 years. Over the past few months, it's been having some minor issues -- weak battery, overheating, slowness, etc. -- annoying, but things I can deal with. Today, however, it had some sort of seizure... I first noticed that I was trying to type a message, and only half of the letters I pressed actually showed up; I tried to close all tabs, figuring that it was just being slow again, but that took a good 30 seconds of pressing the close tabs for it to actually register. At that point, I figured I'd try restarting it (which took at least a minute of frustration, as it kept exiting the power off menu as soon as I got there), but it didn't help once I managed to do so. I then shut it off and let it sit for at least 20 minutes before turning it on again; it seemed a bit more manageable, but only slightly, and got worse by the second.

    I think the issue may be something with the back button. The back button itself doesn't respond (though the tabs button does), but I realized after trying to use it for a bit that it seems to be acting like the back button is pressed on its own agenda -- I would try to click on something, it would began to load, and it would take me back to the page a second later. It also keeps vibrating erratically as if it's responding to my pressing the tabs/back buttons when I'm not doing anything at all.

    Lastly, I noticed a tiny bubble where the glass meets the casing, as if it was somewhat detached in that area or air got in there or something. I just noticed that after I took my case off today and have no idea how long it's been there. That's just something to point out; I don't know whether it's related.

    I've never used this forum before, so apologies if I'm not posting in the right place or something! I'll probably try to get it serviced in the next few days, but I was wondering if anybody else has experienced something like this. Thanks!
    05-07-2017 08:55 PM
  2. Tim1954's Avatar
    Welcome to the forums!
    Turn it off and do cache partition wipe. That's the first thing to do when they get a bit wobbly.
    You can dial *#0*# to get to service mode and check the hardware there.
    Try that first and get back to us with the results.
    05-07-2017 09:20 PM

Similar Threads

  1. Advice on an S6 replacement?
    By DCTF in forum General News & Discussion
    Replies: 5
    Last Post: 05-11-2017, 09:28 PM
  2. Pixel XL/Google App problems
    By Anesthesiologist in forum Google Pixel & Pixel XL
    Replies: 2
    Last Post: 05-08-2017, 10:15 PM
  3. My S6 Active is frozen on the AT&T logo.
    By AC Question in forum Samsung Galaxy S6 active
    Replies: 1
    Last Post: 05-08-2017, 05:36 PM
  4. Accidentally pulled a metal sticker off back of phone
    By Gavin Sumpter in forum Samsung Galaxy S5
    Replies: 3
    Last Post: 05-08-2017, 06:31 AM
LINK TO POST COPIED TO CLIPBOARD