1. AC Question's Avatar
    I have exhausted every troubleshooting I can find after my S6 Edge, SM-G925T, lost Bluetooth after Nougat installed. I have reset several ways, cleared cache, Safe Mode reset, and a few other things through Smart Switch. With some of these I get it to work briefly but with a power cycle or going into standby it is off again and will not start again until the reset or whichever process I do is repeated to get it on again only to go off again.
    Thanks,
    J
    07-06-2017 08:32 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! Was it an official system update pushed over-the-air, or did you download it from some website and install it yourself?
    07-06-2017 04:48 PM
  3. aber57's Avatar
    I installed the update via Samsung SmartSwitch. It is a TMobile phone but I use it on AT&T now. It showed software up to date 2 weeks after TMo rolled out Nougat to that phone for their network users.
    07-06-2017 11:05 PM
  4. aber57's Avatar
    I have no idea why the original post didn't pick up my ID.
    07-06-2017 11:10 PM
  5. B. Diddy's Avatar
    This is curious -- my understanding is that carrier-specific phones won't get official system updates pushed OTA unless the phone is on that carrier's network (even if you're using Smart Switch). If it's a T-Mobile phone, it should get T-Mobile's update, not AT&T's (and only if you were on the T-Mobile network). If it somehow got AT&T's firmware, that might cause some incompatibility. One way this could happen is if the AT&T firmware was previously flashed to the phone -- in that case, things might have worked ok, but the subsequent At&T firmware update wasn't entirely compatible. Is that possible?
    07-08-2017 01:22 PM
  6. aber57's Avatar
    I had the SIM card out of the phone and then tried for weeks to get the update with the phone on wi-fi and no cell connection. I thought that would assure no AT&T crossover issues.
    The phone has all the TMo bloatware stuff showing and no AT&T presence that I can tell.
    I am unsure if there are any bugfix updates that the carriers have issued for S6 Edge since Nougat release. There have been 3 if I remember correctly for my Note 5. SmartSwitch shows it to be up to date if I check it via that app.

    I wonder if rooted phones are seeing these bluetooth issues? S6/S6Edge bluetooth problems are littering the internet but that is purely anecdotal and I have no idea as a percentage how big a deal it is.
    07-08-2017 09:35 PM
  7. B. Diddy's Avatar
    What's the Build Number for your current firmware?
    07-10-2017 12:29 PM
  8. aber57's Avatar
    G925TUVU5FQE1. I looked today on TMo site and that is the one listed. Is there a low risk way to roll back to Marshmellow?
    07-10-2017 10:21 PM
  9. aber57's Avatar
    My reply might be unclear. The build number I listed is what the phone shows and I looked it up to see if that was the right one. It is according to the TMobile site. I thought that SmartSwitch might have grabbed the wrong thing or the phone might have been sensed as an AT&T phone and that might have been loaded
    07-10-2017 10:23 PM
  10. B. Diddy's Avatar
    Ok, thanks for looking that up. At least we can rule out the possibility of incompatibility from using a firmware intended for a different variant.

    Let's go back a little bit -- you mentioned "Safe Mode reset." Do you mean that you booted into Safe Mode, and Bluetooth still failed while in Safe Mode?
    07-10-2017 11:20 PM
  11. aber57's Avatar
    I can't get Bluetooth to come on in safe mode. I just started phone in SM and I can't get Bluetooth to come on in settings or using the in-call screen selection for Bluetooth. Bluetooth did work before. I had it paired to two different cars, maybe 3, and used it often.
    Jut to leave nothing out, this phone had an issue where text displayed on screen was delayed when typing. Not always but a regular occurrence. You'd type 20 something characters w/o seeing them on display and then they would populate. Like when your antiviral is running a scan and busying your processor on a PC.
    07-11-2017 01:12 PM
  12. aber57's Avatar
    I did a full factory reset a while ago and had the same result. BT worked, connected to car, talked over it through car. I then shut down phone and powered it up and BT is off and will not come on
    07-11-2017 02:50 PM
  13. aber57's Avatar
    reset network settings in the general management section of settings also brings it back.
    07-11-2017 02:55 PM
  14. B. Diddy's Avatar
    It might be worth reinstalling the firmware using Smart Switch. Every now and then, the update process might go a little funny, leading to a glitchy copy of the firmware.
    07-12-2017 03:41 PM
  15. aber57's Avatar
    How do I do a re-install. I looked through all the choices on Smart Switch and did not see the option to load it again.
    07-13-2017 12:19 AM
  16. B. Diddy's Avatar
    See the second post in this thread: https://www.sammobile.com/forum/showthread.php?t=29914. Here's how to boot into Download Mode: https://www.androidexplained.com/gal...download-mode/
    07-13-2017 11:10 AM

Similar Threads

  1. S8 cant find Yamaha receivers bluetooth cant connect
    By AC Question in forum Ask a Question
    Replies: 7
    Last Post: 07-17-2017, 12:39 PM
  2. Why is screen black after charging
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 07-06-2017, 04:50 PM
  3. Accessing Car API -Android Nougat
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 07-06-2017, 07:22 AM
  4. Replies: 0
    Last Post: 07-06-2017, 06:58 AM
  5. Replies: 1
    Last Post: 07-06-2017, 06:58 AM
LINK TO POST COPIED TO CLIPBOARD