1. AC Question's Avatar
    I have a Verizon HTC 10 that is unlocked. I'm using it on metro pcs.

    It has the same T Mobile band for LTE that is throughout my neighborhood. I put the correct metro apn settings in. Calls and data both work. But I'm having two issues:

    1: When I make a call data goes out. When it comes back in, LTE won't kick in. Typically have to restart my phone for LTE to kick in.

    2: When it does kick in, it's either working great or not. Example. So I'll do a speed test and only get 1 MBPS. My wife's phone on the same band (band 2) will get 15 MBPS down. I'll test several times, and get the same speeds. Slow downloads. Kick on and off Mobile data with no fix. I'll drive around town and won't get 1 MBPS within 30 minute drive. Out the blue I'll do a speed test 12 hours later and I'll be getting 15 MBPS down in the same place I could only get 1. I'll drive all around town and be getting full speeds.

    So in short: LTE when it's on will either get full speed in my area or under 1 MBPS. Or it will randomly get stuck on 2G.

    Any ideas? With research it seems like some people with the unlocked version had some issues but not with the Verizon one.

    I plan to switch to a Verizon prepaid or MNVO soon but seems like this could be a bigger issue.
    07-08-2017 11:32 PM

Similar Threads

  1. HTC 3.5mm to usb-c adapters now shipping
    By Rob Chew in forum HTC U11
    Replies: 6
    Last Post: 07-11-2017, 02:30 PM
  2. Replies: 1
    Last Post: 07-08-2017, 09:25 PM
  3. Protection password to unlock ?/?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 07-08-2017, 06:54 PM
  4. i cant get my pattern to unlock my phone
    By AC Question in forum Samsung Galaxy S7
    Replies: 1
    Last Post: 07-08-2017, 05:11 PM
  5. i cant get my pattern to unlock my phone
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 07-08-2017, 05:11 PM
LINK TO POST COPIED TO CLIPBOARD