1. AC Question's Avatar
    I recently purchased a OnePlus 5. I then got a monthly SIM deal from iD. For some reason texts and calls are working fine but I can't get any data internet!

    Various websites say that there should be no band issues, and I've seen someone on 3 Mobile saying theirs works fine (iD uses 3 Mobiles network).

    I've contacted iD but they're pretty hopeless and just told me to do the troubleshooting I'd been doing (checking the APN and stuff). I even took it into Carphone Warehouse but they couldn't work it out either.

    Annoyingly I've seen a post on OnePlus forums from someone having the exact same problem, but it's just been closed as 'Solved' with no word on how.

    I'm still not 100% on the exact APN I should have and other settings so hopefully it's just one of those and one of you lovely people can help me out!

    Sorry for this long rambly post.
    07-12-2017 02:03 PM
  2. belodion's Avatar
    🙋Have you seen this? https://www.idmobile.co.uk/help-and-...-your-settings

    If you still have problems, get back to us. https://forums.androidcentral.com/sh...d.php?t=409154
    Laura Knotek likes this.
    07-12-2017 03:30 PM
  3. ProNotion's Avatar
    I just got my OnePlus 5 and have just switched to the iDMobile network on PAYG as it saves me a packet over my previous contract - I had the same issue when my number came across yesterday but I've just resolved it.

    Follow these steps:

    1. Settings
    2. SIM & Network
    3. SIM 1/2 (Select the one with your iDMobile SIM)
    4. Access Point Names
    5. Long click on the iD Internet one
    6. Scroll down and set APN Protocol to IPv4/IPv6
    7. Set APN roaming protocol to IPv4/IPv6
    8. Click the three dots in the top right corner and choose SAVE


    I hope that helps sort yours too!
    belodion and Rich_NZ like this.
    07-21-2017 03:35 AM
  4. Rich_NZ's Avatar
    Awesome thanks for the final piece of the puzzle ProNotion. I'd finally found the APN settings and they looked correct. But it was point 6 and 7 that fixed it.
    First time in my excitement I forgot to save. So for anyone else make sure you remember to save as per step 8.
    Happy days. New phone and new cheap network.
    08-15-2017 02:04 PM
  5. Wolnek's Avatar
    I had the same issue and got it working. If you check the APN settings there is a setting at the bottom: "Bearer" by default it is set to "unspecified". Go check your carrier what technologies they support and then enter them manually. Click the three dots at the top and click save.
    09-07-2017 01:23 PM

Similar Threads

  1. OK Google not working on s8
    By krishnansasikumar in forum Samsung Galaxy S8 & S8+
    Replies: 7
    Last Post: 08-07-2017, 06:50 PM
  2. How to get back the icon for an app on ZTE Speed phone?
    By Little-Acorn in forum Other ZTE Android Phones
    Replies: 2
    Last Post: 07-13-2017, 03:04 PM
  3. Replies: 8
    Last Post: 07-12-2017, 05:50 PM
  4. Replies: 1
    Last Post: 07-12-2017, 01:38 PM
LINK TO POST COPIED TO CLIPBOARD