1. AC Question's Avatar
    Hi, I've got a problem.

    I plugged my phone in to charge and left it alone for a while. When I came back it was already soft rebooting in a loop, and I've got at most only 20seconds on my screen to do anything. Before it reboots Trebuchet crashes. Going into Settings -> Apps -> All -> Trebuchet -> Clear Chache / Data is impossible because of this small timeframe available, also the settings-app crashes after Trebuchet has crashed.
    How can I try to fix this WITHOUT wiping all data?

    Btw: I'm using a Moto G 2014 dual sim xt168, with a CM13 stable release from around a year ago.

    I'm currently trying to backup my relevant app data with adb backup <app>, my problem is that as soon as trebuchet crashes, the backup process gets cancelled. I already tried deleting trebuchets data and rebooting but with no result.

    I tried checking the filesystem with e2fsck and some errors came up. I'm pretty unfamiliar with this. Is a new rom flash inevitable or ist my phone even dying?

    root@titan_umtsds:/ # mount /system
    root@titan_umtsds:/ # mount /data
    mount: '/dev/block/platform/msm_sdcc.1/by-name/userdata'->'/data': Invalid argument
    1|root@titan_umtsds:/ # df
    Filesystem 1K-blocks Used Available Use% Mounted on
    tmpfs 444656 36 444620 1% /dev
    tmpfs 444656 12 444644 1% /tmp
    tmpfs 444656 0 444656 0% /storage
    /dev/block/mmcblk0p36 1112708 761072 351636 69% /system
    /dev/block/mmcblk0p38 5773168 4973376 799792 87% /data
    root@titan_umtsds:/ # umount /system
    root@titan_umtsds:/ # umount /data
    root@titan_umtsds:/ # e2fsck -n /dev/block/mmcblk0p36
    e2fsck 1.42.9 (28-Dec-2013)
    system: clean, 2211/70704 files, 194715/282624 blocks
    root@titan_umtsds:/ # e2fsck -n /dev/block/mmcblk0p38
    e2fsck 1.42.9 (28-Dec-2013)
    ext2fs_open2: Bad magic number in super-block
    e2fsck: Superblock invalid, trying backup blocks...
    e2fsck: Bad magic number in super-block while trying to open /dev/block/mmcblk0p38

    The superblock could not be read or does not describe a correct ext2
    filesystem. If the device is valid and it really contains an ext2
    filesystem (and not swap or ufs or something else), then the superblock
    is corrupt, and you might try running e2fsck with an alternate superblock:
    e2fsck -b 8193 <device>
    07-29-2017 06:37 AM

Similar Threads

  1. Replies: 1
    Last Post: 11-22-2017, 04:41 AM
  2. [App] [4.0+] Discount Calculator
    By sylsau in forum Android Apps
    Replies: 2
    Last Post: 08-25-2017, 08:56 AM
  3. My Samsung GT-S7392 is not turning on after factory reset.
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 07-29-2017, 07:39 AM
  4. Replies: 1
    Last Post: 07-29-2017, 12:52 AM
  5. Stuck on TWRP boot loop on LG G3
    By Wintah in forum LG G3
    Replies: 1
    Last Post: 07-28-2017, 09:22 PM
LINK TO POST COPIED TO CLIPBOARD