1. Hybrid Divide's Avatar
    EDIT: Mods, if this post was placed incorrectly, please move it where it needs to go. Thanks.
    EDIT 2: One time, Prime Video began to load a few images before it force closed.

    Hello Android Central! Long time listener, first time caller. Got a problem I hope you might be able to help me with. Though I admit it's kind of a longshot.

    I have a Lenovo Tab TB-X103F 10.1 inch tablet. It's a budget model that Wal-Mart was selling for real cheap earlier this year. (Only 1GB of RAM.) It originally shipped with Android Marshmallow, but in the months since, TWRP and Lineage OS 14.1 were ported to it. Lineage OS runs great. And even though there's some lag, it's not terrible. Overall a decent tablet.

    Anyway, back when I was on the stock ROM, I loved using the tablet to watch Amazon Prime Video. But it doesn't seem to work for me since I installed Lineage OS. I'll install the Amazon Underground app. That works fine. I install the Amazon Prime Video app from there. When I open the app, it'll come up, look like it's trying to load something, and then close. All I get was that Prime Video has stopped. No error code. No way (as far as I know) to output some kind of log. Nothing that I can use to help diagnose this.

    Oddly, the OP was able to get it to run on his system without a problem.

    I've reinstalled newer builds of the OS with full wipes, even wiping user data. Everything else, including stuff like Youtube works fine, so I know it can still handle streaming video.

    I've also uninstalled the app, reinstalled it, cleared the cache, cleared all data. Everything I can think of. I don't know why it refuses to work on my system, but the OP can still use it on his.

    Even having Root (with and without Magisk) or no root has zero effect. Still get force closes.

    Sorry this ran a bit long, but I hope you can help me figure this out. If you know of some way I can log this to aid in diagnosing the problem, please let me know.

    Thanks very much in advance!
    08-04-2017 12:10 PM
  2. Golfdriver97's Avatar
    Have you tried flashing the oldest build with a full wipe?
    08-04-2017 04:15 PM
  3. Hybrid Divide's Avatar
    Thank you for your reply.

    The oldest build of Lineage for that Lenovo Tablet is a build of Lineage 13. I haven't flashed that, but I have flashed the oldest Lineage 14 build with a full wipe. I think, though, that this is somehow centralized to my device, as the OP has said he hasn't had any issues running it on his tablet.

    And considering the huge amount of people that use Lineage OS, if there had been some more widespread issue with Amazon Prime Video, it would have been mentioned somewhere. And there really hasn't been any mention of this, not here, not on XDA, or anywhere else.
    08-04-2017 04:26 PM
  4. Hybrid Divide's Avatar
    Also, as a new member, are my posts screened initially? I just replied to your question, and I don't see it posted. It's odd. lol

    EDIT: Nevermind! Figured this bit out. Still need help on the Amazon Prime Video, of course. lol
    08-04-2017 04:30 PM
  5. anon(9602380)'s Avatar
    Also, as a new member, are my posts screened initially? I just replied to your question, and I don't see it posted. It's odd. lol
    Yes it is due to scripts used to catch spam on the site. I wouldn't worry as long as you are abiding by forums rules your post will be approved by a Moderator. Thanks.
    08-04-2017 05:14 PM
  6. Golfdriver97's Avatar
    Also, as a new member, are my posts screened initially? I just replied to your question, and I don't see it posted. It's odd. lol

    EDIT: Nevermind! Figured this bit out. Still need help on the Amazon Prime Video, of course. lol
    If you don't mind messing around with the device, I would suggest looking up instructions for logcat pulls, and then do one right after the app failure.

    As for the replies getting moderated...they do but will slow up greatly after you hit I think 20 posts. To echo what firedept said, the Mods will approve them if they are within the rules, but give us a little time. We, as Mods, are volunteers too, and you might be active when we are busy.
    08-04-2017 07:35 PM
  7. Hybrid Divide's Avatar
    Thank you for the reply! I'll look up how to do a logcat pull later tonight and post the results then.

    And no worries on the mod stuff! That wasn't really meant as a criticism, but rather that I was worried something had glitched and eaten my post. Totally understand that you all get busy. Have a good weekend!
    Laura Knotek and Golfdriver97 like this.
    08-04-2017 07:57 PM
  8. Golfdriver97's Avatar
    Thank you for the reply! I'll look up how to do a logcat pull later tonight and post the results then.

    And no worries on the mod stuff! That wasn't really meant as a criticism, but rather that I was worried something had glitched and eaten my post. Totally understand that you all get busy. Have a good weekend!
    The logcat can be helpful to the developer too.

    Edit: I didn't take your reply as a criticism...more like I was posting that just to make sure everything was understood. A good deal of users think we mod as a career.

    Slightly off topic....how are you liking the forums? I saw your intro thread a couple days ago.
    08-05-2017 01:57 PM
  9. Hybrid Divide's Avatar
    These forms are nice. Different from xda, but that's ok. ☺️

    I'll enclose the logcat file with this post. Hard to make sense of, but I think the prime video stuff is about 3/4 of the way down. I launched the app several times in a row to make sure the data would be there.

    Hope this will help.

    And I know this can help the devs, but I doubt Amazon prime video devs will listen to me. Lol

    Thanks for the help!

    EDIT:I'll have to post the logcat from my PC shortly. The system won't let me attach it.
    Golfdriver97 likes this.
    08-05-2017 04:14 PM
  10. Hybrid Divide's Avatar
    OK. Going to try to upload the logcat.txt now.

    Can't seem to upload the file directly, but here's a link to it on my google drive. Best I can seem to do for now. Hope that's ok.

    https://docs.google.com/document/d/1...it?usp=sharing

    Thanks again.
    08-05-2017 04:27 PM
  11. Hybrid Divide's Avatar
    Were any of you able to see the logcat file ok? I realize a .txt file is better, but the forum kept blocking me from uploading it directly for some reason. Google docs was the best I could do.

    Still desperate for a solution to this.

    Thanks very much in advance again.
    08-07-2017 05:23 PM
  12. Golfdriver97's Avatar
    Were any of you able to see the logcat file ok? I realize a .txt file is better, but the forum kept blocking me from uploading it directly for some reason. Google docs was the best I could do.

    Still desperate for a solution to this.

    Thanks very much in advance again.
    I wasn't able to, but I chalked it up the handoff on mobile being difficult. I completely forgot to check on desktop.

    I am not too accustomed to reading logcat pulls. You may need to post this on XDA as the scope of AC is generally geared at more basic questions. XDA is more developer centric, and someone there may be able to help as well.

    Also you may want to consider letting the Lineage developer know about this.
    08-07-2017 07:34 PM
  13. Hybrid Divide's Avatar
    Hello again. Sorry to bump an old topic, but I've had zero luck with this. The guy who ported Lineage over to the tablet seems to have Amazon Video working on his end, at least that's what he says.

    But it doesn't work on mine at all. Even if I do a complete wipe of my internal storage and everything, it still doesn't work. All app and file permissions look correct, too.

    I've managed to capture a new, much shorter logcat file. I'd really appreciate it if someone could take a look at this and see if you can figure anything out. I have a thread about this over at XDA, and I have yet to get even a reply to it.

    Thanks in advance.

    EDIT: It won't let me upload the logcat file, even this shorter one. Here's the link to the XDA thread with a link to the file at the end.

    https://forum.xda-developers.com/gen...1#post73516764
    08-23-2017 06:15 PM
  14. L0n3N1nja's Avatar
    I assume if you have lineage that means the device was rooted. Content streaming sites began blocking rooted devices, I have a rooted Note 10.1 and both Netflix and Hulu quit working on it a few months ago.
    08-23-2017 06:23 PM
  15. L0n3N1nja's Avatar
    I can't confirm Amazon did it with prime video, but Netflix was the one in the news for it, direct tv did it as well. It has to do with DRM and fighting piracy.
    http://www.androidpolice.com/2017/05...l-working-now/
    08-23-2017 06:29 PM
  16. Hybrid Divide's Avatar
    Thanks for the reply!

    I don't think having root or lack thereof has anything to do with this issue. My LG V20 is rooted and Amazon Prime Video runs fine on there. Of course, I use Magisk to hide root. But, I also tried this without root and got the same issue.

    The OP in the lineage thread for this tablet tried it both with and without root and it was fine. I think it's something specific to my system, but I don't have any clues.

    I did work with the stock marshmallow rom, though. And that was rooted, with no Magisk.

    So yeah, it's gotta be something else. Thanks all the same, though!
    08-23-2017 06:41 PM

Similar Threads

  1. Replies: 5
    Last Post: 03-22-2018, 12:12 PM
  2. Honor 8 $259 at Amazon
    By dpham00 in forum Honor 8
    Replies: 48
    Last Post: 08-24-2017, 08:52 PM
  3. please help can't decide on tab s3
    By stsullivan in forum Samsung Galaxy Tab S3
    Replies: 1
    Last Post: 08-04-2017, 11:42 AM
  4. Replies: 1
    Last Post: 08-04-2017, 10:03 AM
LINK TO POST COPIED TO CLIPBOARD