1. AC Question's Avatar
    All other Google apps, Photos, Gmail, etc sync daily. Google Calendar App shows last sync 3 weeks ago. I've turned Calendar Sync on & off several times. No results. I've also cleared calendar cache & calendar data several times.

    All of these efforts produce minimal results. But problem persists.

    WHEN I go to my Google Calendar on my desktop, there are numerous entries showing on there going back months & months that I've deleted on my phone (& those are still deleted on my phone). But they have not deleted on my desktop.

    How do I get my Google Calendar App on phone to sync properly with my Google Calendar on my desktop computer ?
    08-08-2017 04:53 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Have you also tried removing your Google account completely from the phone, then adding it back?
    08-09-2017 02:36 AM
  3. Chris4444's Avatar
    Hi...I'm so leery about trying that because I'm afraid of losing all of my appointments I've added in my Google Calendar app on my phone over the last 3 weeks. Since my phone's calendar app hasn't synced in more than 3 weeks with Google Calendar online, if I remove my Google account from my phone and then add it back in, will all those new entries I've added on my phone over the last 3 weeks be lost ?
    08-09-2017 08:17 AM
  4. B. Diddy's Avatar
    That's true. But can you confirm that those events that you added to the phone but haven't synced with the cloud are actually associated with your Google Calendar account? If your phone has a "Phone Account," it's possible that you're adding those events to the Phone Account's calendar, not your Google account's calendar.
    08-10-2017 12:38 AM
  5. Chris4444's Avatar
    All calendar entries are only added to Google Calendar. My phone calendar is off.
    08-10-2017 05:29 AM
  6. B. Diddy's Avatar
    Which phone do you have? Does it have any battery or RAM-saving features that might be impacting Google Calendar?

    Also, is this for your main calendar (the one labeled "Events"), or a calendar you created? If it's not the Events calendar, then open the Google Calendar app, tap Menu>Settings, tap Show More under your Gmail account, then tap the calendar in question. Make sure the Sync switch there is turned on.
    DroidNewbie9 likes this.
    08-10-2017 10:26 AM
  7. Chris4444's Avatar
    Samsung Galaxy S6. No battery or ram saving features activated.

    All other Google Account Apps sync daily.

    Google Calendar Sync is on, but shows the last sync as over 3 weeks ago. All other Google Account Apps show today's date as last date synced.

    All my calendar entries are for my Google gmail calendar.

    WHEN I add a new entry, the calendar selected is my gmail account calendar. That option is listed under "Save as Event". The button selected is my gmail account calendar. Sync is on.

    I have the latest calendar version on my phone. 4.0.06-337.

    Thanks for your help. This was not an issue until 3 weeks ago. All was working fine until then.
    08-10-2017 03:39 PM
  8. B. Diddy's Avatar
    Ok, try wiping the system cache partition: https://support.t-mobile.com/docs/DOC-21095
    08-10-2017 06:37 PM
  9. Jarrod Gaines's Avatar
    There are several reason why your sync isn't working but don't worry - its fixable!
    Use these solutions in order then re-test- ....no need for all of them!

    1 ) Update your app - go to play store
    2) Settings - apps - calendar - storage "clear data"
    3) Uninstall app - re-install
    4) hard reset your phone - re-install account
    02-27-2018 05:02 AM
  10. gerardangelovelonza's Avatar
    One workaround that I discover is this:

    *search and view you google calendar in Chrome Web Browser (Phone)

    then

    *a prompt will pop-up, asking whether what app would you like for it to be opened

    *choose your google app calendar

    then you can see that they are synchronized now (phone and pc google calendar)

    hope this helps
    07-19-2018 12:31 AM
  11. DroidNewbie9's Avatar
    Does it have any battery or RAM-saving features that might be impacting Google Calendar?
    ^^This ^^ I searched around for awhile, but this answer solved my problem. My dummy self needed to turn off battery saver. Calendars syncing perfectly now.
    B. Diddy likes this.
    01-02-2019 10:29 AM

Similar Threads

  1. 65% battery drain when phone completely off
    By Lalam2442 in forum Samsung Galaxy S7
    Replies: 6
    Last Post: 08-09-2017, 12:22 PM
  2. Why can't i get gmail address into my Galaxy phone
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 08-09-2017, 02:41 AM
  3. Replies: 1
    Last Post: 08-09-2017, 02:38 AM
  4. Why is Predictive Text so stupid now?? It used to work great.
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 08-08-2017, 04:43 PM
  5. What tempered glass can I get in Canada for my LG G4?
    By Chris_P_Bacon in forum Buyers Guides
    Replies: 0
    Last Post: 08-08-2017, 04:42 PM
LINK TO POST COPIED TO CLIPBOARD