1. AC Question's Avatar
    I've had this working fine before, but I've recently switched device and now I can't get it working.

    Basically I'm using the Outlook App to connect to my works Exchange server for email, calendar and contacts. This works fine, however I want to set my Outlook contacts as my devices primary contacts. I did this before by going into the Contacts app and choosing my Outlook Account as my primary account.

    However if I do this now, the Outlook account does not appear. If I go into Settings and then Accounts, the Outlook account is missing. If I try and add it, I get a message telling me this email address is already connected with Exchange. On my old device and also on a colleagues device, there is an Outlook Account listed with the option checked to Sync Contacts.

    How do I get this to display? I've removed and re-added the account many times but it never appears in the Accounts list.
    09-01-2017 07:03 AM
  2. Rukbat's Avatar
    Outlook would probably appear in Accounts/Email or Accounts/Exchange (Or even Accounts/Outlook). Outlook is an email app, so I'd check Accounts/Email first. (The only "primary account" on an Android phone now will be a Google account.)
    09-01-2017 02:15 PM
  3. Natenotnat's Avatar
    Not sure what you mean by Accounts/email or accounts/exchange. Oreo shows email and other accounts like Dropbox and Twitter under system settings/"users and accounts". Outlook no longer appears there, and now it's not possible to sync outlook exchange contacts. The OP and I are looking for help here.
    09-24-2017 10:48 AM
  4. Rukbat's Avatar
    Exchange server ("Outlook) can be installed in so many ways that no single app can work with all of them. But Contacts doesn't work well with all of them, so when it gets updates, some Exchange installations cause problems. The best way to get what you want is to talk to your Exchange administrator and see what s/he has found that works with your particular server setup.
    09-24-2017 01:46 PM
  5. Natenotnat's Avatar
    Thanks. For the benefit of the OP and anyone else struggling with this issue, I found TypeApp works in my case. Once installed, it shows up in Users and Accounts and allows contacts to sync. Also, even though the app doesn't have a calendar, it is able to sync the exchange calendar, now I'm able to have an agenda widget from the calendar app of my choice on my desktop with my work appointments.
    09-25-2017 06:45 AM
  6. jlzimmerman's Avatar
    I moved from a Moto X Pure on Android 6 and never had a problem. Adding a regular Outlook account to sync contacts and the like were simple.

    Now on a Note 8, Outlook was not listed by default like the Moto X did. I setup my personal Outlook email using what was available in the list, the Microsoft Exchange ActiveSync (MEAS) option. When I setup my Outlook account my contacts and calendar still were not showing up in their respective apps. So I downloaded the Outlook app and then tried to setup the account, only to be told that the email address was already in use as an account. I assume it was because the email address was previously setup within the MEAS option. So I removed Outlook and MEAS as accounts and re-added my personal outlook account back into MEAS.

    It worked this time around but I'm don't know why. My outlook contacts and calendar are now merged with my other accounts.
    10-23-2017 10:35 AM
  7. jlzimmerman's Avatar
    I moved from a Moto X Pure on Android 6 and never had a problem. Adding a regular Outlook account to sync contacts was there by default.

    Now on a Note 8, Outlook was not listed by default like the Moto X did. I setup my personal Outlook email using what was available in the list, the Microsoft Exchange ActiveSync (MEAS) option. When I setup my Outlook account my contacts and calendar still were not showing up in their respective apps. So I downloaded the Outlook app and then tried to setup the account, only to be told that the email address was already in use as an account. I assume it was because the email address was previously setup within the MEAS option. So I removed Outlook and MEAS as accounts and re-added my personal outlook account back into MEAS.

    It worked this time around but I'm don't know why. My outlook contacts and calendar are now merged with my other accounts.
    10-23-2017 10:35 AM
  8. Brian Child's Avatar
    We are having this same issue on all Pixel 2 XL phones. I would love it if someone had additional information on this.
    11-29-2017 05:23 PM
  9. dakuth's Avatar
    With my Pixel 2, I found that creating the account in the Outlook app does not make the account appear in the Settings > Accounts area.

    What I wanted to achieve was to read emails in Outlook, but have the Outlook calendar events appear in the Google Calendar app (I like to have my emails separated into "Work" (outlook) and "Personal" (Gmail/Inbox) ... but for my calendar I want both work and personal in the same place so I can see conflicts.)

    So to do this, I went into Settings > Users & accounts > Add account

    I selected Exchange, and went through the settings to create an exchange account - effectively in Gmail.

    This makes emails appear in gmail and events in google calendar. Since I don't want to read my emails in Gmail, I tapped the account in Users & accounts and turned off Sync for emails.

    I then went into the Outlook app and set the account up in there *as well*. This means I can read emails (and check outlook events if I want) in Outook. I had to turn off calendar notifications, though, or else I'd get two.

    In essence I am syncing calendar events through BOTH Gmail (android settings) and the Outlook app. I am syncing emails only in the Outlook app even though I could sync them in Gmail if I wanted.
    01-01-2018 09:15 PM
  10. WillowSaunders's Avatar
    Try this, it worked for me when I couldn't get Outlook to appear in Accounts, or sync contacts:-

    After installing the Outlook App, go into contacts
    click "+ Add contact".
    You will then be asked if you wish to sync contacts.
    Select yes.
    Your contacts should then be listed in your phone contacts, and Outlook should be listed in your phone Accounts. Hopefully.
    01-06-2018 01:24 PM
  11. fullio21's Avatar
    dakuth, i feel your pain.

    there must've been some sort of update with the android os, the widget i was using for combining my calendars (acalendar) that didn't agree a change my organization did when it moved to office365. all i know is that my outlook calendar no longer registers on that widget.

    after countless hours searching for the issue and a resolution, i actually tried your stated fix and unfortunately, it didn't work for me. here's what i did...

    route 1 - downloaded outlook app and set up my account through it. easy set up, just added my email address and password, then again through a server, then authenticated via duo and my email and calendar shows up via the app. the outlook account is NOT showing up under settings > accounts, which i'm guessing is why acalendar isn't reading my outlook calendar. so, fail.

    route 2 - while keeping my work email set up through the outlook app, went your above stated route (settings > accounts > set up account > exchange and set it up that way. got a pop up saying the account was already set up with a different service (office 365) and proceeded anyway. selected exchange from the three microsoft options, and was able to manually select the domain/ username and server settings through exchange. i needed to use outlook.office365.com instead of m.outlook.com in order for it to proceed. then i entered my username and password again and duo to complete the log in. at that point, it sent me back to the page to choose the type of account and said, this account is already set up. ugh.

    route 3 - deleted the account from my outloop app. went to settings > account > add account > selected outlook from the list, proceeded with the above steps and it set up my email and calendar via my vacated outlook app. however, the account STILL did not show up under my account list in the settings and my outlook calendar was still not showing up in acalendar. double ugh

    route 4 - both with my outlook app set up with my email and calendar and with my account deleted from the outlook app, i went to settings > accounts > add account > selected exchange (with the gmail icon) and manually entered the same information as detailed above and i kept getting the 'invalid username and or password' error message and my it dept can't explain why. because my email and calendar work with the outlook app, they can't help any further. triple ugh.

    bottom line is, i still can't get my calendar onto the widget that was working beautifully for several years.

    anybody have any other ideas?? anything would be greatly appreciated.

    btw, i'm using a pixel (first gen) and running 9.0
    04-01-2019 04:37 PM
  12. samiam_68's Avatar
    Took me a while to figure out, but here is the solution.
    Open the outlook app, go to settings, tap on your Outlook.com account, then turn on "Sync contacts".
    The Outlook account will now appear in the "Contacts" app.
    It should take 10-15 minutes for the contacts to sync up, but could take up to several hours.

    Enjoy!
    05-30-2019 09:46 PM

Similar Threads

  1. lg g3 beat stuck in boot, possible bootloop problem
    By AC Question in forum Ask a Question
    Replies: 2
    Last Post: 09-01-2017, 02:21 PM
  2. Samsung Galaxy S3 hotspot only works while phone is set to 3G
    By seanpope in forum Samsung Galaxy S3
    Replies: 1
    Last Post: 09-01-2017, 12:07 PM
  3. I have changed my phone settings.I have changed my security.
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 09-01-2017, 06:26 AM
  4. Showing only Contacts and not hidden contacts
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 08-31-2017, 09:52 PM
LINK TO POST COPIED TO CLIPBOARD