1. bharri25's Avatar
    I have searched the net for 3 days now and done almost everything that has been suggested. Unfortunately I tapped the 'microphone' icon by mistake a few days ago and now cannot get a keyboard up in any app. I only get the 'tap to speak' icon on messaging, gmail, google, chrome, firefox, facebook, google maps etc. In Language and input, virtual keyboard is on google voice typing set to automatic with no icons or options to change. If I go to 'manage keyboards', it is greyed out with no other option. In the google settings 'ok google detection' is in 'pause' mode? It's switch is in a half off position, but greyed out. I can turn it on, but not fully off. When 'tap to speak' comes up, the 'x' to close it does nothing. I have drained battery, gone to every setting in google, followed every solution that has been offered through many internet searches (sometimes the options that are suggested I do not have on my screen). One solution offered was Settings, security, smart lock .. but it needs a pin, and voice either won't activate when tapped (that also happens a lot) or won't put the pin in. The only thing I haven't done is disable google. The disable option is greyed out. I am only able to force stop it and being non technical, don't know if there will be any repercussions. But the keyboard was working just fine with the Google app enabled before. I should be on the latest software. I just update when it tells me to. Can somebody please help me? I do not want to talk to a phone. I just want to get my keyboard back. Thanks
    09-22-2017 01:05 PM
  2. chanchan05's Avatar
    Make sure the phone is connected to the internet. On a PC, open the Google Play Store and login using the same Google account on the phone. Search for a keyboard. Either Gboard or Swiftkey. Or both. Click install, and from the drop down choose the phone with the problem (if you have multiple devices linked to your account). Wait for the keyboards to install on the phone. Activate them.
    09-22-2017 01:17 PM
  3. hallux's Avatar
    Wow, that's a lot of text jammed together.

    One thing I don't see is what phone and OS you're using. On my Nexus 6p running Nougat I get a little keyboard icon in the navigation bar when a text entry box is selected. If I tap that icon, I get to pick which input method to use.
    Robert Frye likes this.
    09-22-2017 01:45 PM
  4. bharri25's Avatar
    Thanks chanchen05. It said Gboard was already installed, but Swiftkey is working fine so far. Thanks for saving me from more frustration.
    09-23-2017 03:37 AM
  5. bharri25's Avatar
    Sorry, Hallux, my frustration caused verbal diarrhea. I just didn't want to get the same suggestions I had tried over and over. Phone is a Lenovo Moto G4 plus running Nougat. There was no keyboard icon, I just kept getting told that I couldn't use a keyboard whilst using voice, but then could not disable ok Google, voice or anything as it was all greyed out with no other options. However all fixed now after suggestion to download Swiftkey. Newbie and totally non technical, so thanks for your input.
    09-23-2017 03:46 AM
  6. Coffee501's Avatar
    I had the same issue and spent days on end trying everything including factory reset..
    Finally read a tip and followed it.

    Turns out I accidentally diabled Gboard. I simply went to apps in settings and enabled the Gboard app. So simple but there is so much to learn.
    11-05-2019 01:57 AM

Similar Threads

  1. Getting closer: Exclusive: T-Mobile, Sprint close to agreeing on deal terms.
    By VW Maverick in forum General Carrier Discussion
    Replies: 12
    Last Post: 11-07-2017, 08:57 AM
  2. Replies: 0
    Last Post: 09-22-2017, 12:50 PM
  3. Can't view WhatsApp photos on PC
    By Quinch 1 in forum Ask a Question
    Replies: 2
    Last Post: 09-22-2017, 12:27 PM
  4. Replies: 2
    Last Post: 09-22-2017, 11:31 AM
  5. Replies: 0
    Last Post: 09-22-2017, 10:51 AM
LINK TO POST COPIED TO CLIPBOARD