1. Android Central Question's Avatar
    Hello. I'm new to posting to this site, though unfortunately not new to using it to help solve Galaxy issues for a few years. I bought a new S7 about a month ago and the only real problem I've found so far is one I can't seem to find a solution to out there. Twice now, I've used the phone to the point where the phone battery hits 0% and it shuts down. Each time, after fully recharging, the phone says it has no cellular signal. I tried a million things the first time - restarted, tried "airplane mode" on/off, ran a ping, checked the IMEI... Finally, the thing that did the trick (or so I thought) was shutting phone down, removing the SIM card and reinserting it. Suddenly, my service was restored. Today, however, it didn't do the trick. So I guess it was something else, or a combination of something else's that worked the first time. Does anyone else have the problem of completely losing signal after full battery drain and recharge? Thanks!
    10-01-2017 11:46 AM
  2. jasonandrews25788's Avatar
    maybe it's the network itself not the phone
    10-01-2017 05:57 PM

Similar Threads

  1. Note 8 and the keyboard
    By missionsparta in forum Samsung Galaxy Note 8
    Replies: 17
    Last Post: 12-16-2017, 12:00 AM
  2. My phone spontaneously reset itself and wiped out some settings
    By arunma in forum Samsung Galaxy Note 8
    Replies: 5
    Last Post: 10-02-2017, 09:58 AM
  3. Why my mobile touch cannot work after a minute of working?
    By Android Central Question in forum Ask a Question
    Replies: 5
    Last Post: 10-01-2017, 09:57 PM
  4. Replies: 1
    Last Post: 10-01-2017, 08:05 PM
  5. Replies: 1
    Last Post: 10-01-2017, 12:41 PM
LINK TO POST COPIED TO CLIPBOARD