1. Android Central Question's Avatar
    The title explains, and there wasnt any external damage happening. i was browsing using chrome

    i couldnt power it off by using the power button (long press not working & cant choose the turn off button selection on display), thus i used force-restart (vol Down + power button)

    keep restarting, gave nothing good. tried the recovery mode to "Wipe cache partition" and rebooting the phone, still not helping

    Any sir willing to give some possible thoughts or tip?

    much thanks,
    10-22-2017 11:07 AM
  2. Rukbat's Avatar
    It sounds as if the digitizer (one of the layers of the screen) went bad. It has to go into a repair shop. (It could be that the cable from the screen to the motherboard came loose, but that would normally affect the display too.)
    10-22-2017 01:14 PM

Similar Threads

  1. I have updated my Nexus 6P to 8.0 but I still see old interface
    By Android Central Question in forum Ask a Question
    Replies: 2
    Last Post: 11-09-2017, 05:40 AM
  2. Hello to all!
    By kellychiss in forum New to the Forums? Introduce Yourself Here!
    Replies: 11
    Last Post: 10-27-2017, 01:04 PM
  3. Replies: 7
    Last Post: 10-23-2017, 11:25 AM
  4. The V30 does great with 4 GB of RAM
    By Rumblee1 in forum LG V30
    Replies: 3
    Last Post: 10-22-2017, 07:20 PM
  5. I have block unknown numbers on, but it is not workinf
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 10-22-2017, 11:31 AM
LINK TO POST COPIED TO CLIPBOARD