1. Android Central Question's Avatar
    I would very much like to disable badge notification on several apps on my phone.
    I have seen people say disable an app like "Badge Provider" or some similarly named app but I'm running 7.0 nougat and there seems to be no such app.
    Similarly when I i disable notifications in the Apps themselves or in the Settings -> App Menu all it does is disable the alert notification but badges remain.

    If anyone knows a way around this I'd be very appreciative of their help.
    11-03-2017 04:39 AM
  2. chanchan05's Avatar
    This would vary from phone to phone based on the manufacturer's implementation as this is not core Android functionality, but a feature of the launcher provided. The easiest and most hassle free way to turn it off is just getting another launcher from the Play Store.
    11-03-2017 04:43 AM
  3. fun account's Avatar
    For A Samsung J5 could you reccommend a launch provider?
    11-03-2017 04:49 AM
  4. fun account's Avatar
    Could you recommend one for a Samsung J5?
    11-03-2017 04:54 AM
  5. hallux's Avatar
    On the apps list in Settings, tap the 3-dot menu in the top right and select to show system apps, BadgeProvider will show there.
    11-03-2017 04:59 AM
  6. chanchan05's Avatar
    Which J5 version is this?

    You can try the following: Nova Launcher, Pixel Launcher, Apex Launcher, Action Launcher.

    Personally I use Nova Launcher.
    11-03-2017 05:01 AM
  7. fun account's Avatar
    It wont let me disable the BadgeProvider. How do I do that?
    11-03-2017 05:09 AM
  8. hallux's Avatar
    Did you try force stopping it first? It's possible Samsung made it more difficult to do.
    11-03-2017 08:00 AM
  9. snowbiker's Avatar
    Did you try force stopping it first? It's possible Samsung made it more difficult to do.
    I also did clear data, clear cache, and restarted phone but when you go back to the app the Force Stop is showing again as if I hadn't selected it. (disable is always greyed out). These badges only started appearing yesterday and there hasn't been update!
    03-03-2018 09:19 AM
  10. Grrr jdkdnjdod's Avatar
    On zte blade a6 lite android 7.1.1 interface mifavor: long press the screen to see the options for the screen, click the option more > bagde.
    On zte blade a6 premium the option is on the settings > notifications > common > badges.
    03-04-2018 04:23 AM

Similar Threads

  1. Android wear connected via bluetooth cannot answer calls on phone
    By Ian Bugeja in forum Android Wear / Wear OS
    Replies: 2
    Last Post: 01-05-2018, 09:37 AM
  2. I am still on Android Wear 1.3
    By pepelepieux in forum Huawei Watch
    Replies: 7
    Last Post: 11-05-2017, 04:23 PM
  3. Recently I see the Android icons on my screen!!!
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 11-03-2017, 10:42 AM
  4. Replies: 1
    Last Post: 11-03-2017, 05:56 AM
  5. Replies: 0
    Last Post: 11-03-2017, 03:11 AM
LINK TO POST COPIED TO CLIPBOARD